5320 C++ Programming Manual: D:/5320/Cpp Directory Reference

5320 C++ Programming Manual
Cpp Directory Reference

Files

file JY5320Core.h
Generated by doxygen 1.9.1


5320 C++ Programming Manual: D:/5320/Cpp/JY5320Core.h File Reference

Typedefs | Enumerations | Functions
JY5320Core.h File Reference

Typedefs

typedef void * JY5320_DeviceHandle
Windows. More...

Enumerations

enum | JY5320_AI_BandWidth { JY5320_AI_BandWidth_25K = 0x0 , JY5320_AI_BandWidth_220K = 0x1 }
enum | JY5320_AI_SampleMode { JY5320_AI_Finite = 0x0 , JY5320_AI_Continuous = 0x1 , JY5320_AI_Single = 0x2 }
enum | JY5320_CI_SampleMode { JY5320_CI_Finite = 0x0 , JY5320_CI_Continuous = 0x1 , JY5320_CI_Single = 0x2 }
enum | JY5320_CO_OUTMode { JY5320_CO_Finite = 0x0 , JY5320_CO_ContinuousWrapping = 0x1 , JY5320_CO_ContinuousNoWrapping = 0x2 , JY5320_CO_Single = 0x3 }
enum | JY5320_AI_TriggerType { JY5320_AI_Immediately = 0x0 , JY5320_AI_Digital = 0x1 , JY5320_AI_Analog = 0x2 , JY5320_AI_Soft = 0x3 }
enum | JY5320_CIO_TriggerType { JY5320_CIO_Immediately = 0x0 , JY5320_CIO_Soft = 0x1 , JY5320_CIO_Digital = 0x2 }
enum | JY5320_TriggerMode { JY5320_StartTrigger = 0x0 , JY5320_ReferenceTrigger = 0x1 }
enum | JY5320_DigitalTriggerEdge { JY5320_Rising = 0x0 , JY5320_Falling = 0x1 }
enum JY5320_DigitalTriggerSource {
JY5320_Inter_AI_StartTrig = 4 , JY5320_Inter_AI_ReferenceTrig = 6 , JY5320_Inter_CIO_0_StartTrig = 39 , JY5320_Inter_CIO_1_StartTrig = 43 ,
JY5320_PXI_Trig0 = 8 , JY5320_PXI_Trig1 = 9 , JY5320_PXI_Trig2 = 10 , JY5320_PXI_Trig3 = 11 ,
JY5320_PXI_Trig4 = 12 , JY5320_PXI_Trig5 = 13 , JY5320_PXI_Trig6 = 14 , JY5320_PXI_Trig7 = 15 ,
JY5320_PFI0 = 16 , JY5320_PFI1 = 17 , JY5320_PFI2 = 18 , JY5320_PFI3 = 19 ,
JY5320_PFI4 = 20 , JY5320_PFI5 = 21 , JY5320_PFI6 = 22 , JY5320_PFI7 = 23 ,
JY5320_PFI8 = 24 , JY5320_PFI9 = 25 , JY5320_PFI10 = 26 , JY5320_PFI11 = 27 ,
JY5320_PFI12 = 28 , JY5320_PFI13 = 29 , JY5320_PFI14 = 30 , JY5320_PFI15 = 31
}
enum JY5320_AnalogTriggerSource {
JY5320_Channel_0 = 0 , JY5320_Channel_1 = 1 , JY5320_Channel_2 = 2 , JY5320_Channel_3 = 3 ,
JY5320_Channel_4 = 4 , JY5320_Channel_5 = 5 , JY5320_Channel_6 = 6 , JY5320_Channel_7 = 7 ,
JY5320_Channel_8 = 8 , JY5320_Channel_9 = 9 , JY5320_Channel_10 = 10 , JY5320_Channel_11 = 11 ,
JY5320_Channel_12 = 12 , JY5320_Channel_13 = 13 , JY5320_Channel_14 = 14 , JY5320_Channel_15 = 15 ,
JY5320_Channel_16 = 16 , JY5320_Channel_17 = 17 , JY5320_Channel_18 = 18 , JY5320_Channel_19 = 19 ,
JY5320_Channel_20 = 20 , JY5320_Channel_21 = 21 , JY5320_Channel_22 = 22 , JY5320_Channel_23 = 23 ,
JY5320_Channel_24 = 24 , JY5320_Channel_25 = 25 , JY5320_Channel_26 = 26 , JY5320_Channel_27 = 27 ,
JY5320_Channel_28 = 28 , JY5320_Channel_29 = 29 , JY5320_Channel_30 = 30 , JY5320_Channel_31 = 31
}
enum | JY5320_AnalogWindowCondition { JY5320_Entering = 0x0 , JY5320_Leaving = 0x1 }
enum | JY5320_AnalogTriggerEdge { JY5320_RisingSlope = 0x0 , JY5320_FallingSlope = 0x1 }
enum | JY5320_AI_ClockSource { JY5320_AI_InternalClock = 0x0 , JY5320_AI_ExternalClock = 0x1 }
enum JY5320_ExternalClockTerminal {
JY5320_Clock_PXI_Trig_0 = 8 , JY5320_Clock_PXI_Trig_1 = 9 , JY5320_Clock_PXI_Trig_2 = 10 , JY5320_Clock_PXI_Trig_3 = 11 ,
JY5320_Clock_PXI_Trig_4 = 12 , JY5320_Clock_PXI_Trig_5 = 13 , JY5320_Clock_PXI_Trig_6 = 14 , JY5320_Clock_PXI_Trig_7 = 15 ,
JY5320_Clock_PFI_0 = 16 , JY5320_Clock_PFI_1 = 17 , JY5320_Clock_PFI_2 = 18 , JY5320_Clock_PFI_3 = 19 ,
JY5320_Clock_PFI_4 = 20 , JY5320_Clock_PFI_5 = 21 , JY5320_Clock_PFI_6 = 22 , JY5320_Clock_PFI_7 = 23 ,
JY5320_Clock_PFI_8 = 24 , JY5320_Clock_PFI_9 = 25 , JY5320_Clock_PFI_10 = 26 , JY5320_Clock_PFI_11 = 27 ,
JY5320_Clock_PFI_12 = 28 , JY5320_Clock_PFI_13 = 29 , JY5320_Clock_PFI_14 = 30 , JY5320_Clock_PFI_15 = 31 ,
JY5320_Inter_AI_SampleClock = 1 , JY5320_Inter_CI0_SampleClock = 37 , JY5320_Inter_CI1_SampleClock = 41 , JY5320_Inter_CO_0_Output = 38 ,
JY5320_Inter_CO_1_Output = 42
}
enum | JY5320_DeviceProperty { JY5320_Independent = 0 , JY5320_MASTER = 1 , JY5320_SLAVE = 3 }
enum JY5320_Signal_Source {
JY5320_AI_StartTrig =4 , JY5320_AI_ReferenceTrig =6 , JY5320_AI_ADC_Trig =36 , JY5320_AI_SampleClock = 1 ,
JY5320_CIO_0_StartTrig = 39 , JY5320_CIO_1_StartTrig = 43 , JY5320_CI0_SampleClock = 37 , JY5320_CI1_SampleClock = 41 ,
JY5320_CO_0_Output = 38 , JY5320_CO_1_Output = 42 , JY5320_CIO_100MHz = 46 , JY5320_CIO_5MHz = 47 ,
JY5320_CIO_100kHz = 48
}
enum JY5320_Signal_Destination {
JY5320_PXITrig0_OUT = 0 , JY5320_PXITrig1_OUT = 1 , JY5320_PXITrig2_OUT = 2 , JY5320_PXITrig3_OUT = 3 ,
JY5320_PXITrig4_OUT = 4 , JY5320_PXITrig5_OUT = 5 , JY5320_PXITrig6_OUT = 6 , JY5320_PXITrig7_OUT = 7 ,
JY5320_PFI0_OUT = 8 , JY5320_PFI1_OUT = 9 , JY5320_PFI2_OUT = 10 , JY5320_PFI3_OUT = 11 ,
JY5320_PFI4_OUT = 12 , JY5320_PFI5_OUT = 13 , JY5320_PFI6_OUT = 14 , JY5320_PFI7_OUT = 15 ,
JY5320_PFI8_OUT = 16 , JY5320_PFI9_OUT = 17 , JY5320_PFI10_OUT = 18 , JY5320_PFI11_OUT = 19 ,
JY5320_PFI12_OUT = 20 , JY5320_PFI13_OUT = 21 , JY5320_PFI14_OUT = 22 , JY5320_PFI15_OUT = 23
}
enum | JY5320_CountTimeBase { JY5320_Internal_Timebase_100M = 0x0 , JY5320_Internal_Timebase_5M = 0x1 , JY5320_Internal_Timebase_100K = 0x2 , JY5320_External_Timebase = 0x3 }
enum | JY5320_CountDirection { JY5320_CI_Count_Up , JY5320_CI_Count_Down , JY5320_CI_Count_External }
enum JY5320_CI_MeasureType {
JY5320_CI_EdgeCount = 0 , JY5320_CI_Measure_FrequencyOrPeriod = 1 , JY5320_CI_Measure_PulseWidth = 2 , JY5320_CI_Measure_SemiPeriod = 3 ,
JY5320_CI_Measure_EdgeSeparation = 4 , JY5320_CI_EncoderX1 = 5 , JY5320_CI_EncoderX2 = 6 , JY5320_CI_EncoderX4 = 7 ,
JY5320_CI_EncoderTwoPulse = 8
}
enum JY5320_InputTerminal {
JY5320_IN_PXI_Trig0 = 8 , JY5320_IN_PXI_Trig1 = 9 , JY5320_IN_PXI_Trig2 = 10 , JY5320_IN_PXI_Trig3 = 11 ,
JY5320_IN_PXI_Trig4 = 12 , JY5320_IN_PXI_Trig5 = 13 , JY5320_IN_PXI_Trig6 = 14 , JY5320_IN_PXI_Trig7 = 15 ,
JY5320_IN_PFI0 = 16 , JY5320_IN_PFI1 = 17 , JY5320_IN_PFI2 = 18 , JY5320_IN_PFI3 = 19 ,
JY5320_IN_PFI4 = 20 , JY5320_IN_PFI5 = 21 , JY5320_IN_PFI6 = 22 , JY5320_IN_PFI7 = 23 ,
JY5320_IN_PFI8 = 24 , JY5320_IN_PFI9 = 25 , JY5320_IN_PFI10 = 26 , JY5320_IN_PFI11 = 27 ,
JY5320_IN_PFI12 = 28 , JY5320_IN_PFI13 = 29 , JY5320_IN_PFI14 = 30 , JY5320_IN_PFI15 = 31 ,
JY5320_IN_CO_0_Output = 38 , JY5320_IN_CO_1_Output = 42 , JY5320_IN_CIO_100MHz = 46 , JY5320_IN_CIO_5MHz = 47 ,
JY5320_IN_CIO_100kHz = 48
}
enum | JY5320_CI_SampleClock { JY5320_CI_ImplicitClock , JY5320_CI_InternalClock , JY5320_CI_ExternalClock }
enum | JY5320_CI_CounterEventSignalIdleState { JY5320_CI_CounterEventSignalIdleState_Low = 0 , JY5320_CI_CounterEventSignalIdleState_High = 1 }
CI Counter Event Signal Idle State. More...
enum | JY5320_CI_LevelState { JY5320_LowLevel = 0 , JY5320_HighLevel = 1 }
enum | JY5320_CI_StartingEdge { JY5320_RisingEdge = 0 , JY5320_FallingEdge = 1 , JY5320_AnyEdge = 2 }
enum | JY5320_CO_IdleState { JY5320_CO_LowLevel = 0 , JY5320_CO_HighLevel = 1 }
enum | JY5320_ReferenceClock { JY5320_Internal = 0 , JY5320_PXIe_Clk100 = 1 }

Functions

JY5320API int | JY5320_Open (int slotNumber, JY5320_DeviceHandle *hDevice)
Open the 5320 series boards using the slot number or the board serial number. More...
JY5320API int | JY5320_OpenByAliasName (const char *aliasName, JY5320_DeviceHandle *hDevice)
Open this 5320 series boards using the board alias name which is set by JYTEK utility JYDM. More...
JY5320API int | JY5320_Close (JY5320_DeviceHandle hDevice)
Close this 5320 board. More...
JY5320API int | JY5320_GetDeviceID (JY5320_DeviceHandle hDevice, int *deviceID)
Obtain the board ID. More...
JY5320API int | JY5320_GetDeviceSerialNumber (JY5320_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber More...
JY5320API int | JY5320_SetDeviceProperty (JY5320_DeviceHandle hDevice, JY5320_DeviceProperty devicePropety)
Set Device Property,this API must be used in Sync function. More...
JY5320API int | JY5320_SetDeviceReferenceClock (JY5320_DeviceHandle hDevice, JY5320_ReferenceClock clockSource)
Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis. More...
JY5320API int | JY5320_SignalRouting (JY5320_DeviceHandle hDevice, JY5320_Signal_Source sourceSignal, JY5320_Signal_Destination distination)
Route a singal from source to destination. More...
JY5320API int | JY5320_DisconnectSignalRouting (JY5320_DeviceHandle hDevice, JY5320_Signal_Destination destination)
Disconnect an established routing. More...
JY5320API int | JY5320_SetDeviceStatusLed (JY5320_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led More...
JY5320API int | JY5320_AI_EnableChannel (JY5320_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JY5320_AI_BandWidth *bandWidth)
Enable AI channels. More...
JY5320API int | JY5320_AI_SetMode (JY5320_DeviceHandle hDevice, JY5320_AI_SampleMode mode)
Set AI sampling mode More...
JY5320API int | JY5320_AI_SetSampleRate (JY5320_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate. More...
JY5320API int | JY5320_AI_SetSamplesToAcquire (JY5320_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount. More...
JY5320API int | JY5320_AI_SetDSMode (JY5320_DeviceHandle hDevice, bool enable)
Set AI DSMode enable,if enable, the AI bandwidth must be 220KHz for 5321 5311 5321B 5311B. More...
JY5320API int | JY5320_AI_Start (JY5320_DeviceHandle hDevice)
Start AI acquisition. More...
JY5320API int | JY5320_AI_ReadData (JY5320_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer. More...
JY5320API int | JY5320_AI_ReadSinglePoint (JY5320_DeviceHandle hDevice, double *readValue, int channelID)
Read single point for each channel to user defined data buffer. More...
JY5320API int | JY5320_AI_Stop (JY5320_DeviceHandle hDevice)
Stop AI acquisition. More...
JY5320API int | JY5320_AI_ReadRawData_U32 (JY5320_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer. More...
JY5320API int | JY5320_AI_ReadRawData_U16 (JY5320_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer. More...
JY5320API int | JY5320_AI_SetSampleClock (JY5320_DeviceHandle hDevice, JY5320_AI_ClockSource clockSource, JY5320_ExternalClockTerminal terminal, double expectedRate)
Set AI sampling clock. More...
JY5320API int | JY5320_AI_SetStartTriggerType (JY5320_DeviceHandle hDevice, JY5320_AI_TriggerType triggerType)
Set AI start trigger type,the triggerType is defined by enum JY5320_AI_TriggerType. More...
JY5320API int | JY5320_AI_SetDigitalStartTrigger (JY5320_DeviceHandle hDevice, JY5320_DigitalTriggerSource triggerSource, JY5320_DigitalTriggerEdge triggerEdge)
Set AI digital start trigger,the triggerSource is defined by enum JY5320_DigitalTriggerSource, the triggerEdge is defined by enum JY5320_DigitalTriggerEdge. More...
JY5320API int | JY5320_AI_SetAnalogWindowStartTrigger (JY5320_DeviceHandle hDevice, JY5320_AnalogTriggerSource triggerSource, JY5320_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerCondition is defined by enum JY5320_AnalogWindowCondition. More...
JY5320API int | JY5320_AI_SetAnalogHysteresisStartTrigger (JY5320_DeviceHandle hDevice, JY5320_AnalogTriggerSource triggerSource, JY5320_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerEdge is defined by enum JY5320_AnalogTriggerEdge. More...
JY5320API int | JY5320_AI_SetAnalogEdgeStartTrigger (JY5320_DeviceHandle hDevice, JY5320_AnalogTriggerSource triggerSource, JY5320_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge start trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerEdge is defined by enum JY5320_AnalogTriggerEdge. More...
JY5320API int | JY5320_AI_SetReferenceTriggerType (JY5320_DeviceHandle hDevice, JY5320_AI_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY5320_AI_TriggerType More...
JY5320API int | JY5320_AI_SetDigitalReferenceTrigger (JY5320_DeviceHandle hDevice, JY5320_DigitalTriggerSource triggerSource, JY5320_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger.the triggerSource is defined by enum JY5320_DigitalTriggerSource, the triggerEdge is defined by enum JY5320_DigitalTriggerEdge. More...
JY5320API int | JY5320_AI_SetAnalogWindowReferenceTrigger (JY5320_DeviceHandle hDevice, JY5320_AnalogTriggerSource triggerSource, JY5320_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window reference trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerCondition is defined by enum JY5320_AnalogTriggerCondition. More...
JY5320API int | JY5320_AI_SetAnalogHysteresisReferenceTrigger (JY5320_DeviceHandle hDevice, JY5320_AnalogTriggerSource triggerSource, JY5320_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerEdge is defined by enum JY5320_AnalogTriggerEdge. More...
JY5320API int | JY5320_AI_SetAnalogEdgeReferenceTrigger (JY5320_DeviceHandle hDevice, JY5320_AnalogTriggerSource triggerSource, JY5320_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge reference trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerEdge is defined by enum JY5320_AnalogTriggerEdge. More...
JY5320API int | JY5320_AI_SetPreTriggerSamples (JY5320_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0. More...
JY5320API int | JY5320_AI_SetReTriggerCount (JY5320_DeviceHandle hDevice, unsigned long long reTriggerCount)
Set AI retrigger count. More...
JY5320API int | JY5320_AI_SendSoftTrigger (JY5320_DeviceHandle hDevice, JY5320_TriggerMode triggerMode)
Send the software trigger signal for AI. More...
JY5320API int | JY5320_AI_WaitUntilDone (JY5320_DeviceHandle hDevice, bool *done)
Check if AI acquisition is completed in finite mode. More...
JY5320API int | JY5320_AI_CheckBufferStatus (JY5320_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AI device buffer status. More...
JY5320API int | JY5320_DI_AddLines (JY5320_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
Enabled DI channels. More...
JY5320API int | JY5320_DI_ReadSinglePoint_U16 (JY5320_DeviceHandle hDevice, unsigned short *readValue)
Read DI single point.The data type is ushort. More...
JY5320API int | JY5320_DI_ReadSinglePoint (JY5320_DeviceHandle hDevice, bool *readValues, int portID)
Read DI single point.The data type is bool. More...
JY5320API int | JY5320_DI_Start (JY5320_DeviceHandle hDevice)
Start DI acquisition. More...
JY5320API int | JY5320_DI_Stop (JY5320_DeviceHandle hDevice)
Stop DI acquisition. More...
JY5320API int | JY5320_DO_AddLines (JY5320_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
Enabled DO channels More...
JY5320API int | JY5320_DO_WriteSinglePoint_U16 (JY5320_DeviceHandle hDevice, unsigned short writeValue)
Write DO single point.The data type is ushort. More...
JY5320API int | JY5320_DO_WriteSinglePoint (JY5320_DeviceHandle hDevice, bool *writeValues, int portID)
Write DO single point.The data type is bool. More...
JY5320API int | JY5320_DO_Start (JY5320_DeviceHandle hDevice)
Start digital signal output. More...
JY5320API int | JY5320_DO_Stop (JY5320_DeviceHandle hDevice)
Stop digital signal output. More...
JY5320API int | JY5320_DisableAICalibration (JY5320_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default false More...
JY5320API int | JY5320_CI_EnableChannel (JY5320_DeviceHandle hDevice, unsigned int channel)
Enables CI channel.There are 4 counter,from 0 to 3. More...
JY5320API int | JY5320_CI_SetCounterType (JY5320_DeviceHandle hDevice, unsigned int channel, JY5320_CI_MeasureType measureType)
Set CI measure type More...
JY5320API int | JY5320_CI_SetSignalReverse (JY5320_DeviceHandle hDevice, unsigned int channel, int signalReverse)
Set the Signal Reverse terminal. More...
JY5320API int | JY5320_CI_SetCounterParament (JY5320_DeviceHandle hDevice, unsigned int channel, int initCount, JY5320_CountDirection countDirection)
Set CI count parameter More...
JY5320API int | JY5320_CI_SetZReloadEnabled (JY5320_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode. More...
JY5320API int | JY5320_CI_SetStartingEdge (JY5320_DeviceHandle hDevice, unsigned int channel, JY5320_CI_StartingEdge startingEdge)
Set starting edge More...
JY5320API int | JY5320_CI_SetFirstSampleClock (JY5320_DeviceHandle hDevice, unsigned int channel, bool ignore)
Set the first sample clock data ignore or not More...
JY5320API int | JY5320_CI_SetMode (JY5320_DeviceHandle hDevice, unsigned int channel, JY5320_CI_SampleMode mode)
Set counter input mode, the mode is defined by enum JY5320_CI_SampleMode. More...
JY5320API int | JY5320_CI_SetSampleClock (JY5320_DeviceHandle hDevice, unsigned int channel, JY5320_CI_SampleClock clock, JY5320_ExternalClockTerminal terminal, double rate)
Set counter input sampling clock source. More...
JY5320API int | JY5320_CI_SetTimeBase (JY5320_DeviceHandle hDevice, unsigned int channel, JY5320_CountTimeBase timebaseSrc, double externalTimebaseFreq, double *actualTimebaseFreq)
Set counter input time base,the time base defined by enum JY5320_CountTimeBase. More...
JY5320API int | JY5320_CI_SetSamplesToAcquire (JY5320_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToAcquire)
Set samples to acquire in finite mode.The samples range is 1 to 4M. More...
JY5320API int | JY5320_CI_SetEdgeCountEvent (JY5320_DeviceHandle hDevice, unsigned int channel, JY5320_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal More...
JY5320API int | JY5320_CI_SetPauseTriggerLevel (JY5320_DeviceHandle hDevice, unsigned int channel, bool enable, JY5320_CI_LevelState pauseTriggerActiveLevel)
Config CI pause trigger. More...
JY5320API int | JY5320_CI_ReadSingleCountValue (JY5320_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type: JY5320_CI_EdgeCount、JY5320_CI_EncoderX1、 JY5320_CI_EncoderX2 、 JY5320_CI_EncoderX4 、JY5320_CI_EncoderTwoPulse. More...
JY5320API int | JY5320_CI_ReadSingleMeasureValue (JY5320_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows. More...
JY5320API int | JY5320_CI_ReadCountValues (JY5320_DeviceHandle hDevice, unsigned int channel, unsigned int *countValues, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the count values, this API is supprot CI Type ：JY5320_CI_EdgeCount、JY5320_CI_EncoderX1、 JY5320_CI_EncoderX2 、 JY5320_CI_EncoderX4 、JY5320_CI_EncoderTwoPulse. More...
JY5320API int | JY5320_CI_ReadMeasureValues (JY5320_DeviceHandle hDevice, unsigned int channel, double *measureValues1, double *measureValues2, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the measured values, this API only support CI Type for JY5320_CI_Measure_EdgeSeparation JY5320_CI_Measure_Pulse JY5320_CI_Measure_Frequency JY5320_CI_Measure_Period JY5320_CI_Measure_SemiPeriod for JY5320_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s. More...
JY5320API int | JY5320_CI_Start (JY5320_DeviceHandle hDevice, unsigned int channel)
Start Counter input. More...
JY5320API int | JY5320_CI_Stop (JY5320_DeviceHandle hDevice, unsigned int channel)
Stop Counter input. More...
JY5320API int | JY5320_CI_CheckBufferStatus (JY5320_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CI task buffer status. More...
JY5320API int | JY5320_CI_SendSoftTrigger (JY5320_DeviceHandle hDevice, int channel)
Send the software trigger signal for CI. More...
JY5320API int | JY5320_CI_SetStartTriggerType (JY5320_DeviceHandle hDevice, int channel, JY5320_CIO_TriggerType triggerTyp)
Set CI start trigger type,the triggerType is defined by enum JY5320_CI_TriggerType. More...
JY5320API int | JY5320_CI_SetDigitalStartTrigger (JY5320_DeviceHandle hDevice, int channel, JY5320_DigitalTriggerSource triggerSource, JY5320_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JY5320_DigitalTriggerSource, the triggerEdge is defined by enum JY5320_DigitalTriggerEdge. More...
JY5320API int | JY5320_CI_SetSourceTerminal (JY5320_DeviceHandle hDevice, int channel, JY5320_InputTerminal sourceTerminal)
Set source terminal. More...
JY5320API int | JY5320_CI_SetGateTerminal (JY5320_DeviceHandle hDevice, int channel, JY5320_InputTerminal gateTerminal)
Set gate terminal. More...
JY5320API int | JY5320_CI_SetAuxTerminal (JY5320_DeviceHandle hDevice, int channel, JY5320_InputTerminal auxTerminal)
Set aux terminal. More...
JY5320API int | JY5320_CI_SetOutTerminal (JY5320_DeviceHandle hDevice, int channel, JY5320_Signal_Destination outTerminal)
Set out terminal. More...
JY5320API int | JY5320_CO_EnableChannel (JY5320_DeviceHandle hDevice, unsigned int channel)
Enabled counter output channel. More...
JY5320API int | JY5320_CO_SetCounterParament (JY5320_DeviceHandle hDevice, unsigned int channel, int pulseCount, JY5320_CO_IdleState IdleState, double delay)
Set CO parameter. More...
JY5320API int | JY5320_CO_SetFrequency (JY5320_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency More...
JY5320API int | JY5320_CO_SetFrequencyOnFly (JY5320_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set the output pulse frequency of the counter in real time. More...
JY5320API int | JY5320_CO_WriteData (JY5320_DeviceHandle hDevice, int channel, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses. More...
JY5320API int | JY5320_CO_CheckBufferStatus (JY5320_DeviceHandle hDevice, unsigned int channel, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CO task buffer status. More...
JY5320API int | JY5320_CO_CheckCounterStatus (JY5320_DeviceHandle hDevice, unsigned int channel, unsigned int *pulseTransfered, bool *underflow)
Check counter output status. More...
JY5320API int | JY5320_CO_WaitUntilDone (JY5320_DeviceHandle hDevice, unsigned int channel, bool *done)
Check counter output complete status. More...
JY5320API int | JY5320_CO_SetSamplesToUpdate (JY5320_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToUpdate)
Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples. More...
JY5320API int | JY5320_CO_Start (JY5320_DeviceHandle hDevice, unsigned int channel)
Start counter output. More...
JY5320API int | JY5320_CO_Stop (JY5320_DeviceHandle hDevice, unsigned int channel)
Stop counter output. More...
JY5320API int | JY5320_CO_SendSoftTrigger (JY5320_DeviceHandle hDevice, int channel)
Send the software trigger signal. More...
JY5320API int | JY5320_CO_SetMode (JY5320_DeviceHandle hDevice, unsigned int channel, JY5320_CO_OUTMode mode)
Set counter output mode, the mode defined by enum JY5320_CO_UpdateMode. More...
JY5320API int | JY5320_CO_SetStartTriggerType (JY5320_DeviceHandle hDevice, int channel, JY5320_CIO_TriggerType triggerTyp)
Set CO start trigger type,the triggerType is defined by enum JY5320_AI_TriggerType More...
JY5320API int | JY5320_CO_SetDigitalStartTrigger (JY5320_DeviceHandle hDevice, int channel, JY5320_DigitalTriggerSource triggerSource, JY5320_DigitalTriggerEdge triggerEdge)
Set CO digital start trigger,the triggerSource is defined by enum JY5320_DigitalTriggerSource, the triggerEdge is defined by enum JY5320_DigitalTriggerEdge. More...
JY5320API int | JY5320_CO_SetTimeBase (JY5320_DeviceHandle hDevice, unsigned int channel, JY5320_CountTimeBase timebaseSrc, double externalTimebaseFreq, double *actualTimebaseFreq)
Set counter output time base,the time base defined by enum JY5320_CountTimeBase. More...
JY5320API int | JY5320_CO_SetSourceTerminal (JY5320_DeviceHandle hDevice, int channel, JY5320_InputTerminal sourceTerminal)
Set CO source terminal. More...
JY5320API int | JY5320_CO_SetOutTerminal (JY5320_DeviceHandle hDevice, int channel, JY5320_Signal_Destination outTerminal)
Set CO out terminal. More...

Typedef Documentation

◆ JY5320_DeviceHandle

typedef void* JY5320_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY5320_AI_BandWidth

enum JY5320_AI_BandWidth
Enumerator
JY5320_AI_BandWidth_25K | AI BandWidth is 50KHz.
JY5320_AI_BandWidth_220K | AI BandWidth is 220KHz.

◆ JY5320_AI_ClockSource

enum JY5320_AI_ClockSource
Enumerator
JY5320_AI_InternalClock | Internal Clock Source.
JY5320_AI_ExternalClock | External Clock Source.

◆ JY5320_AI_SampleMode

enum JY5320_AI_SampleMode
Enumerator
JY5320_AI_Finite | AI Finite mode.
JY5320_AI_Continuous | AI Continuous mode.
JY5320_AI_Single | AI Single Mode.

◆ JY5320_AI_TriggerType

enum JY5320_AI_TriggerType
Enumerator
JY5320_AI_Immediately | AI Immediately trigger.
JY5320_AI_Digital | AI Digital trigger.
JY5320_AI_Analog | AI Analog trigger.
JY5320_AI_Soft | AI Soft trigger.

◆ JY5320_AnalogTriggerEdge

enum JY5320_AnalogTriggerEdge
Enumerator
JY5320_RisingSlope | Rsing edge for Analog trigger.
JY5320_FallingSlope | Falling edge for Analog trigger.

◆ JY5320_AnalogTriggerSource

enum JY5320_AnalogTriggerSource
Enumerator
JY5320_Channel_0
JY5320_Channel_1
JY5320_Channel_2
JY5320_Channel_3
JY5320_Channel_4
JY5320_Channel_5
JY5320_Channel_6
JY5320_Channel_7
JY5320_Channel_8
JY5320_Channel_9
JY5320_Channel_10
JY5320_Channel_11
JY5320_Channel_12
JY5320_Channel_13
JY5320_Channel_14
JY5320_Channel_15
JY5320_Channel_16
JY5320_Channel_17
JY5320_Channel_18
JY5320_Channel_19
JY5320_Channel_20
JY5320_Channel_21
JY5320_Channel_22
JY5320_Channel_23
JY5320_Channel_24
JY5320_Channel_25
JY5320_Channel_26
JY5320_Channel_27
JY5320_Channel_28
JY5320_Channel_29
JY5320_Channel_30
JY5320_Channel_31

◆ JY5320_AnalogWindowCondition

enum JY5320_AnalogWindowCondition
Enumerator
JY5320_Entering | Analog Window trigger condition is Entering.
JY5320_Leaving | Analog Window trigger condition is Leaving.

◆ JY5320_CI_CounterEventSignalIdleState

enum JY5320_CI_CounterEventSignalIdleState

CI Counter Event Signal Idle State.

Enumerator
JY5320_CI_CounterEventSignalIdleState_Low | Low Level as the CI Counter Event Signal Idle State.
JY5320_CI_CounterEventSignalIdleState_High | High Level as the CI Counter Event Signal Idle State.

◆ JY5320_CI_LevelState

enum JY5320_CI_LevelState
Enumerator
JY5320_LowLevel | Low Level as the pause trigger active level.
JY5320_HighLevel | High Level as the pause trigger active level.

◆ JY5320_CI_MeasureType

enum JY5320_CI_MeasureType
Enumerator
JY5320_CI_EdgeCount | Edge count.
JY5320_CI_Measure_FrequencyOrPeriod | FrequencyOrPeriod Measurement.
JY5320_CI_Measure_PulseWidth | Pulse Measurement.
JY5320_CI_Measure_SemiPeriod | SemiPeriod Measurement.
JY5320_CI_Measure_EdgeSeparation | Two Edge Separation Measurement.
JY5320_CI_EncoderX1 | Quadrature Encoded X1.
JY5320_CI_EncoderX2 | Quadrature Encoded X2.
JY5320_CI_EncoderX4 | Quadrature Encoded X4.
JY5320_CI_EncoderTwoPulse | Two Pulse Encoder.

◆ JY5320_CI_SampleClock

enum JY5320_CI_SampleClock
Enumerator
JY5320_CI_ImplicitClock | CI Implicit Clock.
JY5320_CI_InternalClock | CI Internal Clock.
JY5320_CI_ExternalClock | CI External Clock.

◆ JY5320_CI_SampleMode

enum JY5320_CI_SampleMode
Enumerator
JY5320_CI_Finite | CI Finite mode.
JY5320_CI_Continuous | CI Continuous mode.
JY5320_CI_Single | CI Single mode.

◆ JY5320_CI_StartingEdge

enum JY5320_CI_StartingEdge
Enumerator
JY5320_RisingEdge | Rising edge as the start edge.
JY5320_FallingEdge | Falling edge as the start edge.
JY5320_AnyEdge | any edge edge as the start edge.

◆ JY5320_CIO_TriggerType

enum JY5320_CIO_TriggerType
Enumerator
JY5320_CIO_Immediately | CI Immediately trigger.
JY5320_CIO_Soft | CI Soft trigger.
JY5320_CIO_Digital | CI Digital trigger.

◆ JY5320_CO_IdleState

enum JY5320_CO_IdleState
Enumerator
JY5320_CO_LowLevel | Low Level as the co idle state.
JY5320_CO_HighLevel | High Level as the co idle state.

◆ JY5320_CO_OUTMode

enum JY5320_CO_OUTMode
Enumerator
JY5320_CO_Finite | CO Finite mode.
JY5320_CO_ContinuousWrapping | CO ContinuousWrapping mode.
JY5320_CO_ContinuousNoWrapping | CO ContinuousNoWrapping mode.
JY5320_CO_Single | CO Finite mode.

◆ JY5320_CountDirection

enum JY5320_CountDirection
Enumerator
JY5320_CI_Count_Up | Increases count.
JY5320_CI_Count_Down | Reduction count.
JY5320_CI_Count_External | External terminal determines the count direction.

◆ JY5320_CountTimeBase

enum JY5320_CountTimeBase
Enumerator
JY5320_Internal_Timebase_100M |
JY5320_Internal_Timebase_5M | 100MHz Internal TimeBase
JY5320_Internal_Timebase_100K | 5MHz Internal TimeBase
JY5320_External_Timebase | 100KHz Internal TimeBase

◆ JY5320_DeviceProperty

enum JY5320_DeviceProperty
Enumerator
JY5320_Independent |
JY5320_MASTER | Device as independent.
JY5320_SLAVE | Device as master.

◆ JY5320_DigitalTriggerEdge

enum JY5320_DigitalTriggerEdge
Enumerator
JY5320_Rising | Rsing edge for digital trigger.
JY5320_Falling | Falling edge for digital trigger.

◆ JY5320_DigitalTriggerSource

enum JY5320_DigitalTriggerSource
Enumerator
JY5320_Inter_AI_StartTrig |
JY5320_Inter_AI_ReferenceTrig | AI_StartTrig as the source signal to rout.
JY5320_Inter_CIO_0_StartTrig | AI_ReferenceTrig as the source signal to rout.
JY5320_Inter_CIO_1_StartTrig |
JY5320_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY5320_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY5320_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY5320_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY5320_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY5320_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY5320_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY5320_PXI_Trig7 | PXI_Trig7 as the digital trigger source.
JY5320_PFI0 | PFI_0 as the digital trigger source.
JY5320_PFI1 | PFI_1 as the digital trigger source.
JY5320_PFI2 | PFI_2 as the digital trigger source.
JY5320_PFI3 | PFI_3 as the digital trigger source.
JY5320_PFI4 | PFI_4 as the digital trigger source.
JY5320_PFI5 | PFI_5 as the digital trigger source.
JY5320_PFI6 | PFI_6 as the digital trigger source.
JY5320_PFI7 | PFI_7 as the digital trigger source.
JY5320_PFI8 | PFI_8 as the digital trigger source.
JY5320_PFI9 | PFI_9 as the digital trigger source.
JY5320_PFI10 | PFI_10 as the digital trigger source.
JY5320_PFI11 | PFI_11 as the digital trigger source.
JY5320_PFI12 | PFI_12 as the digital trigger source.
JY5320_PFI13 | PFI_13 as the digital trigger source.
JY5320_PFI14 | PFI_14 as the digital trigger source.
JY5320_PFI15 | PFI_15 as the digital trigger source.

◆ JY5320_ExternalClockTerminal

enum JY5320_ExternalClockTerminal
Enumerator
JY5320_Clock_PXI_Trig_0 | PXI_Trig0 as External Clock Source.
JY5320_Clock_PXI_Trig_1 | PXI_Trig1 as External Clock Source.
JY5320_Clock_PXI_Trig_2 | PXI_Trig2 as External Clock Source.
JY5320_Clock_PXI_Trig_3 | PXI_Trig3 as External Clock Source.
JY5320_Clock_PXI_Trig_4 | PXI_Trig4 as External Clock Source.
JY5320_Clock_PXI_Trig_5 | PXI_Trig5 as External Clock Source.
JY5320_Clock_PXI_Trig_6 | PXI_Trig6 as External Clock Source.
JY5320_Clock_PXI_Trig_7 | PXI_Trig7 as External Clock Source.
JY5320_Clock_PFI_0 | PFI0 as External Clock Source.
JY5320_Clock_PFI_1 | PFI1 as External Clock Source.
JY5320_Clock_PFI_2 | PFI2 as External Clock Source.
JY5320_Clock_PFI_3 | PFI3 as External Clock Source.
JY5320_Clock_PFI_4 | PFI4 as External Clock Source.
JY5320_Clock_PFI_5 | PFI5 as External Clock Source.
JY5320_Clock_PFI_6 | PFI6 as External Clock Source.
JY5320_Clock_PFI_7 | PFI7 as External Clock Source.
JY5320_Clock_PFI_8 | PFI8 as External Clock Source.
JY5320_Clock_PFI_9 | PFI9 as External Clock Source.
JY5320_Clock_PFI_10 | PFI10 as External Clock Source.
JY5320_Clock_PFI_11 | PFI11 as External Clock Source.
JY5320_Clock_PFI_12 | PFI12 as External Clock Source.
JY5320_Clock_PFI_13 | PFI13 as External Clock Source.
JY5320_Clock_PFI_14 | PFI14 as External Clock Source.
JY5320_Clock_PFI_15 | PFI15 as External Clock Source.
JY5320_Inter_AI_SampleClock | CI0_SampleClock as other task External Clock Source.
JY5320_Inter_CI0_SampleClock | CI0_SampleClock as other task External Clock Source.
JY5320_Inter_CI1_SampleClock | CI1_SampleClock as other task External Clock Source.
JY5320_Inter_CO_0_Output | CO_0_Output as other task External Clock Source.
JY5320_Inter_CO_1_Output | CO_1_Output as other task External Clock Source.

◆ JY5320_InputTerminal

enum JY5320_InputTerminal
Enumerator
JY5320_IN_PXI_Trig0 | PXI_Trig0 as Input Terminal.
JY5320_IN_PXI_Trig1 | PXI_Trig1 as Input Terminal.
JY5320_IN_PXI_Trig2 | PXI_Trig2 as Input Terminal.
JY5320_IN_PXI_Trig3 | PXI_Trig3 as Input Terminal.
JY5320_IN_PXI_Trig4 | PXI_Trig4 as Input Terminal.
JY5320_IN_PXI_Trig5 | PXI_Trig5 as Input Terminal.
JY5320_IN_PXI_Trig6 | PXI_Trig6 as Input Terminal.
JY5320_IN_PXI_Trig7 | PXI_Trig7 as Input Terminal.
JY5320_IN_PFI0 | PFI_0 as Input Terminal.
JY5320_IN_PFI1 | PFI_1 as Input Terminal.
JY5320_IN_PFI2 | PFI_2 as Input Terminal.
JY5320_IN_PFI3 | PFI_3 as Input Terminal.
JY5320_IN_PFI4 | PFI_4 as Input Terminal.
JY5320_IN_PFI5 | PFI_5 as Input Terminal.
JY5320_IN_PFI6 | PFI_6 as Input Terminal.
JY5320_IN_PFI7 | PFI_7 as Input Terminal.
JY5320_IN_PFI8 | PFI_8 as Input Terminal.
JY5320_IN_PFI9 | PFI_9 as Input Terminal.
JY5320_IN_PFI10 | PFI_10 as the Input Terminal.
JY5320_IN_PFI11 | PFI_11 as the Input Terminal.
JY5320_IN_PFI12 | PFI_12 as the Input Terminal.
JY5320_IN_PFI13 | PFI_13 as the Input Terminal.
JY5320_IN_PFI14 | PFI_14 as the Input Terminal.
JY5320_IN_PFI15 | PFI_15 as the Input Terminal.
JY5320_IN_CO_0_Output | CO_0_Output as Input Terminal.
JY5320_IN_CO_1_Output | CO_1_Output as Input Terminal.
JY5320_IN_CIO_100MHz | Counter 100MHz timebase as Input Terminal.
JY5320_IN_CIO_5MHz | Counter 5MHz timebase as Input Terminal.
JY5320_IN_CIO_100kHz | Counter 100kHz timebase as Input Terminal.

◆ JY5320_ReferenceClock

enum JY5320_ReferenceClock
Enumerator
JY5320_Internal | The onboard 25 MHz as JY5320_ReferenceClock.
JY5320_PXIe_Clk100 | The PXIe chassis 100MHz as JY5320_ReferenceClock, only for PXIe module.

◆ JY5320_Signal_Destination

enum JY5320_Signal_Destination
Enumerator
JY5320_PXITrig0_OUT |
JY5320_PXITrig1_OUT | PXITrig0 as the signal desition to rout.
JY5320_PXITrig2_OUT | PXITrig1 as the signal desition to rout.
JY5320_PXITrig3_OUT | PXITrig2 as the signal desition to rout.
JY5320_PXITrig4_OUT | PXITrig3 as the signal desition to rout.
JY5320_PXITrig5_OUT | PXITrig4 as the signal desition to rout.
JY5320_PXITrig6_OUT | PXITrig5 as the signal desition to rout.
JY5320_PXITrig7_OUT | PXITrig6 as the signal desition to rout.
JY5320_PFI0_OUT | PXITrig7 as the signal desition to rout.
JY5320_PFI1_OUT | PFI0 as the signal desition to rout.
JY5320_PFI2_OUT | PFI1 as the signal desition to rout.
JY5320_PFI3_OUT | PFI2 as the signal desition to rout.
JY5320_PFI4_OUT | PFI3 as the signal desition to rout.
JY5320_PFI5_OUT | PFI4 as the signal desition to rout.
JY5320_PFI6_OUT | PFI5 as the signal desition to rout.
JY5320_PFI7_OUT | PFI6 as the signal desition to rout.
JY5320_PFI8_OUT | PFI7 as the signal desition to rout.
JY5320_PFI9_OUT | PFI8 as the signal desition to rout.
JY5320_PFI10_OUT | PFI9 as the signal desition to rout.
JY5320_PFI11_OUT | PFI10 as the signal desition to rout.
JY5320_PFI12_OUT | PFI11 as the signal desition to rout.
JY5320_PFI13_OUT | PFI12 as the signal desition to rout.
JY5320_PFI14_OUT | PFI13 as the signal desition to rout.
JY5320_PFI15_OUT | PFI14 as the signal desition to rout.

◆ JY5320_Signal_Source

enum JY5320_Signal_Source
Enumerator
JY5320_AI_StartTrig |
JY5320_AI_ReferenceTrig | AI_StartTrig as the source signal to rout.
JY5320_AI_ADC_Trig | AI_ReferenceTrig as the source signal to rout.
JY5320_AI_SampleClock | AI_ADC_Trig as the source signal to rout.
JY5320_CIO_0_StartTrig | AI_SampleClock as the source signal to rout.
JY5320_CIO_1_StartTrig |
JY5320_CI0_SampleClock | CI0_SampleClock as other task External Clock Source.
JY5320_CI1_SampleClock | CI1_SampleClock as other task External Clock Source.
JY5320_CO_0_Output | CO_0_Output as other task External Clock Source.
JY5320_CO_1_Output | CO_1_Output as other task External Clock Source.
JY5320_CIO_100MHz | Counter 100MHz timebase as other task External Clock Source.
JY5320_CIO_5MHz | Counter 5MHz timebase as other task External Clock Source.
JY5320_CIO_100kHz | Counter 100kHz timebase as other task External Clock Source.

◆ JY5320_TriggerMode

enum JY5320_TriggerMode
Enumerator
JY5320_StartTrigger | Start trigger mode.
JY5320_ReferenceTrigger | Reference trigger mode.

Function Documentation

◆ JY5320_AI_CheckBufferStatus()

JY5320API int JY5320_AI_CheckBufferStatus | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check AI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5320_AI_EnableChannel()

JY5320API int JY5320_AI_EnableChannel | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JY5320_AI_BandWidth * | bandWidth
 | ) |  |

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
bandWidth | array[channelCount] of bandwidth for each channel, default 25KHz. Invalid for 5321 5311 5321B 5311B
Returns
0 if success or other error code

◆ JY5320_AI_ReadData()

JY5320API int JY5320_AI_ReadData | ( | JY5320_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5320_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5320_AI_ReadRawData_U16()

JY5320API int JY5320_AI_ReadRawData_U16 | ( | JY5320_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5320_AI_EnableChannel. This API only support PXI/PCI/USB-5321、 PXI/PCI/USB-5311、PXI/PCI/USB-5320、 PXI/PCI/USB-5310

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5320_AI_ReadRawData_U32()

JY5320API int JY5320_AI_ReadRawData_U32 | ( | JY5320_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5320_AI_EnableChannel. This API only support PXI/PCI/USB-5321B and PXI/PCI/USB-5311B

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5320_AI_ReadSinglePoint()

JY5320API int JY5320_AI_ReadSinglePoint | ( | JY5320_DeviceHandle | hDevice,
 |  | double * | readValue,
 |  | int | channelID
 | ) |  |

Read single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY5320_AI_SendSoftTrigger()

JY5320API int JY5320_AI_SendSoftTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_TriggerMode | triggerMode
 | ) |  |

Send the software trigger signal for AI.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if success or other error code

◆ JY5320_AI_SetAnalogEdgeReferenceTrigger()

JY5320API int JY5320_AI_SetAnalogEdgeReferenceTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AnalogTriggerSource | triggerSource,
 |  | JY5320_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold
 | ) |  |

Set AI analog edge reference trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerEdge is defined by enum JY5320_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
threshold | threshold
Returns
0 if success or other error code

◆ JY5320_AI_SetAnalogEdgeStartTrigger()

JY5320API int JY5320_AI_SetAnalogEdgeStartTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AnalogTriggerSource | triggerSource,
 |  | JY5320_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold
 | ) |  |

Set AI analog edge start trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerEdge is defined by enum JY5320_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5320_AI_SetAnalogHysteresisReferenceTrigger()

JY5320API int JY5320_AI_SetAnalogHysteresisReferenceTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AnalogTriggerSource | triggerSource,
 |  | JY5320_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerEdge is defined by enum JY5320_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5320_AI_SetAnalogHysteresisStartTrigger()

JY5320API int JY5320_AI_SetAnalogHysteresisStartTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AnalogTriggerSource | triggerSource,
 |  | JY5320_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerEdge is defined by enum JY5320_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5320_AI_SetAnalogWindowReferenceTrigger()

JY5320API int JY5320_AI_SetAnalogWindowReferenceTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AnalogTriggerSource | triggerSource,
 |  | JY5320_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog window reference trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerCondition is defined by enum JY5320_AnalogTriggerCondition.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5320_AI_SetAnalogWindowStartTrigger()

JY5320API int JY5320_AI_SetAnalogWindowStartTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AnalogTriggerSource | triggerSource,
 |  | JY5320_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog window start trigger,the triggerSource is defined by enum JY5320_AnalogTriggerSource, the triggerCondition is defined by enum JY5320_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5320_AI_SetDigitalReferenceTrigger()

JY5320API int JY5320_AI_SetDigitalReferenceTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_DigitalTriggerSource | triggerSource,
 |  | JY5320_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital reference trigger.the triggerSource is defined by enum JY5320_DigitalTriggerSource, the triggerEdge is defined by enum JY5320_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source
triggerEdge | AI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5320_AI_SetDigitalStartTrigger()

JY5320API int JY5320_AI_SetDigitalStartTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_DigitalTriggerSource | triggerSource,
 |  | JY5320_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital start trigger,the triggerSource is defined by enum JY5320_DigitalTriggerSource, the triggerEdge is defined by enum JY5320_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5320_AI_SetDSMode()

JY5320API int JY5320_AI_SetDSMode | ( | JY5320_DeviceHandle | hDevice,
 |  | bool | enable
 | ) |  |

Set AI DSMode enable,if enable, the AI bandwidth must be 220KHz for 5321 5311 5321B 5311B.

default : disable(false)

Parameters
hDevice | device handle
enable | true: enable oversample; false: disable oversample
Returns
0 if success or other error code

◆ JY5320_AI_SetMode()

JY5320API int JY5320_AI_SetMode | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AI_SampleMode | mode
 | ) |  |

Set AI sampling mode

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JY5320_AI_SampleMode.
Returns
0 if success or other error code

◆ JY5320_AI_SetPreTriggerSamples()

JY5320API int JY5320_AI_SetPreTriggerSamples | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5320_AI_SetReferenceTriggerType()

JY5320API int JY5320_AI_SetReferenceTriggerType | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AI_TriggerType | triggerType
 | ) |  |

Set AI reference trigger type,the triggerType is defined by enum JY5320_AI_TriggerType

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5320_AI_SetReTriggerCount()

JY5320API int JY5320_AI_SetReTriggerCount | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned long long | reTriggerCount
 | ) |  |

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY5320_AI_SetSampleClock()

JY5320API int JY5320_AI_SetSampleClock | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AI_ClockSource | clockSource,
 |  | JY5320_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set AI sampling clock.

the source of the sampling clock defined by enum JY5320_ClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | AI sampling clock source
terminal | external terminal
expectedRate | AI external clock frequency
Returns
0 if success or other error code

◆ JY5320_AI_SetSampleRate()

JY5320API int JY5320_AI_SetSampleRate | ( | JY5320_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5320_AI_SetSamplesToAcquire()

JY5320API int JY5320_AI_SetSamplesToAcquire | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire
 | ) |  |

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 256M samples / channelCount.
Returns
0 if success or other error code

◆ JY5320_AI_SetStartTriggerType()

JY5320API int JY5320_AI_SetStartTriggerType | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_AI_TriggerType | triggerType
 | ) |  |

Set AI start trigger type,the triggerType is defined by enum JY5320_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI start trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5320_AI_Start()

JY5320API int JY5320_AI_Start ( JY5320_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5320_AI_Stop()

JY5320API int JY5320_AI_Stop ( JY5320_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5320_AI_WaitUntilDone()

JY5320API int JY5320_AI_WaitUntilDone | ( | JY5320_DeviceHandle | hDevice,
 |  | bool * | done
 | ) |  |

Check if AI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true:completed, false:not yet completed.
Returns
0 if success or other error code

◆ JY5320_CI_CheckBufferStatus()

JY5320API int JY5320_CI_CheckBufferStatus | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check CI task buffer status.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5320_CI_EnableChannel()

JY5320API int JY5320_CI_EnableChannel | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Enables CI channel.There are 4 counter,from 0 to 3.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5320_CI_ReadCountValues()

JY5320API int JY5320_CI_ReadCountValues | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValues,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Counter reads the count values, this API is supprot CI Type ：JY5320_CI_EdgeCount、JY5320_CI_EncoderX1、 JY5320_CI_EncoderX2 、 JY5320_CI_EncoderX4 、JY5320_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel
countValues | user buffer,the buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | timeout time in microsecond
actualReadLength | return value, the actual length of the data read.
Returns
0 if success or other error code

◆ JY5320_CI_ReadMeasureValues()

JY5320API int JY5320_CI_ReadMeasureValues | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValues1,
 |  | double * | measureValues2,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Counter reads the measured values, this API only support CI Type for JY5320_CI_Measure_EdgeSeparation JY5320_CI_Measure_Pulse JY5320_CI_Measure_Frequency JY5320_CI_Measure_Period JY5320_CI_Measure_SemiPeriod for JY5320_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s.

for JY5320_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s. for JY5320_CI_Measure_SemiPeriod type, the measureValues1 is signal period, the unit is s,the measureValues2 invalid. for JY5320_CI_Measure_Frequency type, the measureValues1 is signal frequency, the unit is Hz. for JY5320_CI_Measure_Period type, the measureValues2 is signal period, the unit is s. The JY5320_CI_Measure_Period type and JY5320_CI_Measure_Frequency type is same time measurement, user need to read both measurements simultaneously.

Parameters
hDevice | device handle
channel | counter input channel
measureValues | user buffer.The buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | measure timeout time in microsecond
actualReadLength | reture the actual length of the data read
Returns
0 if success or other error code

◆ JY5320_CI_ReadSingleCountValue()

JY5320API int JY5320_CI_ReadSingleCountValue | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue
 | ) |  |

Counter reads a single count value, this API supports the CI Type: JY5320_CI_EdgeCount、JY5320_CI_EncoderX1、 JY5320_CI_EncoderX2 、 JY5320_CI_EncoderX4 、JY5320_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JY5320_CI_ReadSingleMeasureValue()

JY5320API int JY5320_CI_ReadSingleMeasureValue | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut
 | ) |  |

Reads a single counter measurement as follows.

for JY5320_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JY5320_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY5320_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JY5320_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY5320_CI_SendSoftTrigger()

JY5320API int JY5320_CI_SendSoftTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel
 | ) |  |

Send the software trigger signal for CI.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5320_CI_SetAuxTerminal()

JY5320API int JY5320_CI_SetAuxTerminal | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_InputTerminal | auxTerminal
 | ) |  |

Set aux terminal.

Parameters
hDevice | device handle
channel | counter output channel
auxTerminal | aux terminal
Returns
0 if success or other error code

◆ JY5320_CI_SetCounterParament()

JY5320API int JY5320_CI_SetCounterParament | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JY5320_CountDirection | countDirection
 | ) |  |

Set CI count parameter

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JY5320_CountDirection
Returns
0 if success or other error code

◆ JY5320_CI_SetCounterType()

JY5320API int JY5320_CI_SetCounterType | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5320_CI_MeasureType | measureType
 | ) |  |

Set CI measure type

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JY5320_CI_MeasureType
Returns
0 if success or other error code

◆ JY5320_CI_SetDigitalStartTrigger()

JY5320API int JY5320_CI_SetDigitalStartTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_DigitalTriggerSource | triggerSource,
 |  | JY5320_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set CI digital start trigger.the triggerSource is defined by enum JY5320_DigitalTriggerSource, the triggerEdge is defined by enum JY5320_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5320_CI_SetEdgeCountEvent()

JY5320API int JY5320_CI_SetEdgeCountEvent | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5320_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold
 | ) |  |

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JY5320_CI_SetFirstSampleClock()

JY5320API int JY5320_CI_SetFirstSampleClock | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | ignore
 | ) |  |

Set the first sample clock data ignore or not

Parameters
hDevice | device handle
channel | counter input channel
ignore | ignore the first sample clock data. true : ignore; false: not ignore
Returns
0 if success or other error code

◆ JY5320_CI_SetGateTerminal()

JY5320API int JY5320_CI_SetGateTerminal | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_InputTerminal | gateTerminal
 | ) |  |

Set gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | gate terminal
Returns
0 if success or other error code

◆ JY5320_CI_SetMode()

JY5320API int JY5320_CI_SetMode | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5320_CI_SampleMode | mode
 | ) |  |

Set counter input mode, the mode is defined by enum JY5320_CI_SampleMode.

Parameters
hDevice | device handle
channel | counter input channel
mode | counter input mode, Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5320_CI_SetOutTerminal()

JY5320API int JY5320_CI_SetOutTerminal | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_Signal_Destination | outTerminal
 | ) |  |

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5320_CI_SetPauseTriggerLevel()

JY5320API int JY5320_CI_SetPauseTriggerLevel | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5320_CI_LevelState | pauseTriggerActiveLevel
 | ) |  |

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5320_CI_SetSampleClock()

JY5320API int JY5320_CI_SetSampleClock | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5320_CI_SampleClock | clock,
 |  | JY5320_ExternalClockTerminal | terminal,
 |  | double | rate
 | ) |  |

Set counter input sampling clock source.

If the clockType is internal, user need to define sampleRate, if the clockType is JY5320_CI_ImplicitClk, the sample rate determine by the measuer signal.

Parameters
hDevice | device handle
channel | counter input channel
clockType | counter input clock type. Option: internal clock 、 implicit clock、external clock.
terminal | external clock terminal,defined by enum JY5320_ExternalClockTerminal
rate | external clock frequency,when clockType is implicit clock or external clock. when clockType is Internal clock, the rate is internal sample rate
Returns
0 if success or other error code

◆ JY5320_CI_SetSamplesToAcquire()

JY5320API int JY5320_CI_SetSamplesToAcquire | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToAcquire
 | ) |  |

Set samples to acquire in finite mode.The samples range is 1 to 4M.

Parameters
hDevice | device handle
channel | counter input channel
samplesToAcquire | CI finite samples to acquire, samples range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5320_CI_SetSignalReverse()

JY5320API int JY5320_CI_SetSignalReverse | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | signalReverse
 | ) |  |

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
signalReverse | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JY5320_CI_SetSourceTerminal()

JY5320API int JY5320_CI_SetSourceTerminal | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_InputTerminal | sourceTerminal
 | ) |  |

Set source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JY5320_CI_SetStartingEdge()

JY5320API int JY5320_CI_SetStartingEdge | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5320_CI_StartingEdge | startingEdge
 | ) |  |

Set starting edge

Parameters
hDevice | device handle
channel | counter input channel
startingEdge | starting edge.
Returns
0 if success or other error code

◆ JY5320_CI_SetStartTriggerType()

JY5320API int JY5320_CI_SetStartTriggerType | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_CIO_TriggerType | triggerTyp
 | ) |  |

Set CI start trigger type,the triggerType is defined by enum JY5320_CI_TriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5320_CI_SetTimeBase()

JY5320API int JY5320_CI_SetTimeBase | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5320_CountTimeBase | timebaseSrc,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq
 | ) |  |

Set counter input time base,the time base defined by enum JY5320_CountTimeBase.

Parameters
hDevice | device handle
channel | counter input channel
timebaseSrc | counter timebase source
externalTimebaseFreq | timebase frequnency when the source is external timebase
actualTimebaseFreq | return the counter actual timebase frequency
Returns
0 if success or other error code

◆ JY5320_CI_SetZReloadEnabled()

JY5320API int JY5320_CI_SetZReloadEnabled | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled
 | ) |  |

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JY5320_CI_Start()

JY5320API int JY5320_CI_Start | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5320_CI_Stop()

JY5320API int JY5320_CI_Stop | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5320_Close()

JY5320API int JY5320_Close ( JY5320_DeviceHandle hDevice )

Close this 5320 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5320_CO_CheckBufferStatus()

JY5320API int JY5320_CO_CheckBufferStatus | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check CO task buffer status.

Parameters
hDevice | device handle
channel | counter output channel
avaliableSamples | number of CO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5320_CO_CheckCounterStatus()

JY5320API int JY5320_CO_CheckCounterStatus | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | pulseTransfered,
 |  | bool * | underflow
 | ) |  |

Check counter output status.

Parameters
hDevice | device handle
channel | counter output channel
pulseTransfered | The number of pulse that have been transfered
overrun | true:overflow, false:not overflow.
Returns
0 if success or other error code

◆ JY5320_CO_EnableChannel()

JY5320API int JY5320_CO_EnableChannel | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Enabled counter output channel.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5320_CO_SendSoftTrigger()

JY5320API int JY5320_CO_SendSoftTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel
 | ) |  |

Send the software trigger signal.

Parameters
hDevice | device handle
channel | counter channel
Returns
0 if success or other error code

◆ JY5320_CO_SetCounterParament()

JY5320API int JY5320_CO_SetCounterParament | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JY5320_CO_IdleState | IdleState,
 |  | double | delay
 | ) |  |

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
delay | counter output delay, unit:s. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = delay + (5 / timebase)
Returns
0 if success or other error code

◆ JY5320_CO_SetDigitalStartTrigger()

JY5320API int JY5320_CO_SetDigitalStartTrigger | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_DigitalTriggerSource | triggerSource,
 |  | JY5320_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set CO digital start trigger,the triggerSource is defined by enum JY5320_DigitalTriggerSource, the triggerEdge is defined by enum JY5320_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter channel
triggerSource | CO digital start trigger source
triggerEdge | CO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5320_CO_SetFrequency()

JY5320API int JY5320_CO_SetFrequency | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks
 | ) |  |

Set counter output pulse frequency

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if success or other error code

◆ JY5320_CO_SetFrequencyOnFly()

JY5320API int JY5320_CO_SetFrequencyOnFly | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks
 | ) |  |

Set the output pulse frequency of the counter in real time.

After the output starts, you can call this interface to modify the pulse frequency in real time.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if success or other error code

◆ JY5320_CO_SetMode()

JY5320API int JY5320_CO_SetMode | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5320_CO_OUTMode | mode
 | ) |  |

Set counter output mode, the mode defined by enum JY5320_CO_UpdateMode.

Parameters
hDevice | device handle
mode | CO mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5320_CO_SetOutTerminal()

JY5320API int JY5320_CO_SetOutTerminal | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_Signal_Destination | outTerminal
 | ) |  |

Set CO out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5320_CO_SetSamplesToUpdate()

JY5320API int JY5320_CO_SetSamplesToUpdate | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToUpdate
 | ) |  |

Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.

Parameters
hDevice | device handle
channel | counter output channel
sampleToUpdate | number of CO samples per channel. Data range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5320_CO_SetSourceTerminal()

JY5320API int JY5320_CO_SetSourceTerminal | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_InputTerminal | sourceTerminal
 | ) |  |

Set CO source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JY5320_CO_SetStartTriggerType()

JY5320API int JY5320_CO_SetStartTriggerType | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5320_CIO_TriggerType | triggerTyp
 | ) |  |

Set CO start trigger type,the triggerType is defined by enum JY5320_AI_TriggerType

Parameters
hDevice | device handle
channel | counter channel
triggerType | CO start trigger type. Options:immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5320_CO_SetTimeBase()

JY5320API int JY5320_CO_SetTimeBase | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5320_CountTimeBase | timebaseSrc,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq
 | ) |  |

Set counter output time base,the time base defined by enum JY5320_CountTimeBase.

Parameters
hDevice | device handle
channel | counter input channel
timebaseSrc | counter timebase source
externalTimebaseFreq | timebase frequnency when the source is external timebase
actualTimebaseFreq | return the counter actual timebase frequency
Returns
0 if success or other error code

◆ JY5320_CO_Start()

JY5320API int JY5320_CO_Start | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5320_CO_Stop()

JY5320API int JY5320_CO_Stop | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5320_CO_WaitUntilDone()

JY5320API int JY5320_CO_WaitUntilDone | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done
 | ) |  |

Check counter output complete status.

Parameters
hDevice | device handle
channel | counter output channel
done | true :counter output complete, false:counter output not complete
Returns
0 if success or other error code

◆ JY5320_CO_WriteData()

JY5320API int JY5320_CO_WriteData | ( | JY5320_DeviceHandle | hDevice,
 |  | int | channel,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.

Parameters
hDevice | device handle
channel | counter output channel
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*3.
dataLength | length of pulse output
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5320_DI_AddLines()

JY5320API int JY5320_DI_AddLines | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount
 | ) |  |

Enabled DI channels.

Parameters
hDevice | device handle
port | array[portCount] containing port IDs
portCount | number of ports to be enabled
Returns
0 if success or other error code

◆ JY5320_DI_ReadSinglePoint()

JY5320API int JY5320_DI_ReadSinglePoint | ( | JY5320_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | portID
 | ) |  |

Read DI single point.The data type is bool.

one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified port values,the readValues Length must equal to 2, and the order is form line 0 to line 1. when the portID is -1, read all enabled ports values,the readValues Length must equal to 2*portCount(In function JY5320_DI_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 2.
portID | port number
Returns
0 if success or other error code

◆ JY5320_DI_ReadSinglePoint_U16()

JY5320API int JY5320_DI_ReadSinglePoint_U16 | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned short * | readValue
 | ) |  |

Read DI single point.The data type is ushort.

There are 8 ports, from 0 to 7. Each port has 2 lines, from 0 to 1. There are a total of 16 lines from 0 to 15. Each bit represents one line.

Parameters
hDevice device handle
readValue read all port values. each bit from low to high represents one line.
Returns
0 if success or other error code

◆ JY5320_DI_Start()

JY5320API int JY5320_DI_Start ( JY5320_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5320_DI_Stop()

JY5320API int JY5320_DI_Stop ( JY5320_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5320_DisableAICalibration()

JY5320API int JY5320_DisableAICalibration | ( | JY5320_DeviceHandle | hDevice,
 |  | bool | DisableCalibration
 | ) |  |

Disable AI calibration coefficient, default false

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5320_DisconnectSignalRouting()

JY5320API int JY5320_DisconnectSignalRouting | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_Signal_Destination | destination
 | ) |  |

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY5320_DestinationSignal
Returns
0 if success or other error code

◆ JY5320_DO_AddLines()

JY5320API int JY5320_DO_AddLines | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount
 | ) |  |

Enabled DO channels

Parameters
hDevice | device handle
port | array[portCount] containing port IDs.
portCount | number of ports to be enabled
Returns
0 if success or other error code

◆ JY5320_DO_Start()

JY5320API int JY5320_DO_Start ( JY5320_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5320_DO_Stop()

JY5320API int JY5320_DO_Stop ( JY5320_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5320_DO_WriteSinglePoint()

JY5320API int JY5320_DO_WriteSinglePoint | ( | JY5320_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | portID
 | ) |  |

Write DO single point.The data type is bool.

one bool defined one line status.

Parameters
hDevice | device handle
writeValues | write the specified port values,the writeValues Length must equal to 2, and the order is form line 0 to line 1. when the portID is -1, write all enabled ports values,the writeValues Length must equal to 2*portCount(In function JY5320_DO_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 2.
portID | port number
Returns
0 if success or other error code

◆ JY5320_DO_WriteSinglePoint_U16()

JY5320API int JY5320_DO_WriteSinglePoint_U16 | ( | JY5320_DeviceHandle | hDevice,
 |  | unsigned short | writeValue
 | ) |  |

Write DO single point.The data type is ushort.

There are 8 ports, from 0 to 7. Each port has 2 lines, from 0 to 1. There are a total of 16 lines from 0 to 15. Each bit represents one line.

Parameters
hDevice device handle
writeValue wirte the all port values. each bit from low to high represents one line.
Returns
0 if success or other error code

◆ JY5320_GetDeviceID()

JY5320API int JY5320_GetDeviceID | ( | JY5320_DeviceHandle | hDevice,
 |  | int * | deviceID
 | ) |  |

Obtain the board ID.

The 5320 is a series of boards. The PXIe-5321 board ID is Ox5321, PXIe-5311 board ID is Ox5311. The PCIe-5321 board ID is OxF321, PCIe-5311 board ID is OxF311. The USB-5321 board ID is OxB321, USB-5311 board ID is OxB311. The PXIe-5321B board ID is Ox5B21, PXIe-5311B board ID is Ox5B11. The PCIe-5321B board ID is OxAB21, PCIe-5311B board ID is OxAB11. The USB-5321B board ID is OxBB21, USB-5311B board ID is OxBB11. The PXIe-5320 board ID is Ox5320, PXIe-5310 board ID is Ox5310. The PCIe-5320 board ID is OxF320, PCIe-5310 board ID is OxF310. The USB-5320 board ID is OxB320, USB-5310 board ID is OxB310.

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY5320_GetDeviceSerialNumber()

JY5320API int JY5320_GetDeviceSerialNumber | ( | JY5320_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length
 | ) |  |

Obtain the device serialNumber

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY5320_Open()

JY5320API int JY5320_Open | ( | int | slotNumber,
 |  | JY5320_DeviceHandle * | hDevice
 | ) |  |

Open the 5320 series boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY5320_OpenByAliasName()

JY5320API int JY5320_OpenByAliasName | ( | const char * | aliasName,
 |  | JY5320_DeviceHandle * | hDevice
 | ) |  |

Open this 5320 series boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY5320_SetDeviceProperty()

JY5320API int JY5320_SetDeviceProperty | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_DeviceProperty | devicePropety
 | ) |  |

Set Device Property,this API must be used in Sync function.

Parameters
hDevice | device handle
devicePropety | defined by enum JY5320_DeviceProperty
Returns
0 if success or other error code

◆ JY5320_SetDeviceReferenceClock()

JY5320API int JY5320_SetDeviceReferenceClock | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_ReferenceClock | clockSource
 | ) |  |

Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis.

PCIe device only supports 25MHz timebase.

Parameters
hDevice | device handle
clkSource | ReferenceClock source defined by enum JY5320_ReferenceClock
Returns
0 if success or other error code

◆ JY5320_SetDeviceStatusLed()

JY5320API int JY5320_SetDeviceStatusLed | ( | JY5320_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency
 | ) |  |

Control Front Panel Status Led

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY5320_SignalRouting()

JY5320API int JY5320_SignalRouting | ( | JY5320_DeviceHandle | hDevice,
 |  | JY5320_Signal_Source | sourceSignal,
 |  | JY5320_Signal_Destination | distination
 | ) |  |

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum Y5320_SourceSignal and JY5320_DestinationSignal. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY5320_SourceSignal
destination | destination of the signal defined by enum JY5320_DestinationSignal
Returns
0 if success or other error code


5320 C++ Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 5320


5320 C++ Programming Manual: D:/5320 Directory Reference

  • D:
  • 5320
5320 Directory Reference

Directories

directory Cpp


5320 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 5320
▼ Cpp
JY5320Core.h


5320 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- j -

  • JY5320_AI_ADC_Trig : JY5320Core.h
  • JY5320_AI_Analog : JY5320Core.h
  • JY5320_AI_BandWidth : JY5320Core.h
  • JY5320_AI_BandWidth_220K : JY5320Core.h
  • JY5320_AI_BandWidth_25K : JY5320Core.h
  • JY5320_AI_CheckBufferStatus() : JY5320Core.h
  • JY5320_AI_ClockSource : JY5320Core.h
  • JY5320_AI_Continuous : JY5320Core.h
  • JY5320_AI_Digital : JY5320Core.h
  • JY5320_AI_EnableChannel() : JY5320Core.h
  • JY5320_AI_ExternalClock : JY5320Core.h
  • JY5320_AI_Finite : JY5320Core.h
  • JY5320_AI_Immediately : JY5320Core.h
  • JY5320_AI_InternalClock : JY5320Core.h
  • JY5320_AI_ReadData() : JY5320Core.h
  • JY5320_AI_ReadRawData_U16() : JY5320Core.h
  • JY5320_AI_ReadRawData_U32() : JY5320Core.h
  • JY5320_AI_ReadSinglePoint() : JY5320Core.h
  • JY5320_AI_ReferenceTrig : JY5320Core.h
  • JY5320_AI_SampleClock : JY5320Core.h
  • JY5320_AI_SampleMode : JY5320Core.h
  • JY5320_AI_SendSoftTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogEdgeReferenceTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogEdgeStartTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogHysteresisReferenceTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogHysteresisStartTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogWindowReferenceTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogWindowStartTrigger() : JY5320Core.h
  • JY5320_AI_SetDigitalReferenceTrigger() : JY5320Core.h
  • JY5320_AI_SetDigitalStartTrigger() : JY5320Core.h
  • JY5320_AI_SetDSMode() : JY5320Core.h
  • JY5320_AI_SetMode() : JY5320Core.h
  • JY5320_AI_SetPreTriggerSamples() : JY5320Core.h
  • JY5320_AI_SetReferenceTriggerType() : JY5320Core.h
  • JY5320_AI_SetReTriggerCount() : JY5320Core.h
  • JY5320_AI_SetSampleClock() : JY5320Core.h
  • JY5320_AI_SetSampleRate() : JY5320Core.h
  • JY5320_AI_SetSamplesToAcquire() : JY5320Core.h
  • JY5320_AI_SetStartTriggerType() : JY5320Core.h
  • JY5320_AI_Single : JY5320Core.h
  • JY5320_AI_Soft : JY5320Core.h
  • JY5320_AI_Start() : JY5320Core.h
  • JY5320_AI_StartTrig : JY5320Core.h
  • JY5320_AI_Stop() : JY5320Core.h
  • JY5320_AI_TriggerType : JY5320Core.h
  • JY5320_AI_WaitUntilDone() : JY5320Core.h
  • JY5320_AnalogTriggerEdge : JY5320Core.h
  • JY5320_AnalogTriggerSource : JY5320Core.h
  • JY5320_AnalogWindowCondition : JY5320Core.h
  • JY5320_AnyEdge : JY5320Core.h
  • JY5320_Channel_0 : JY5320Core.h
  • JY5320_Channel_1 : JY5320Core.h
  • JY5320_Channel_10 : JY5320Core.h
  • JY5320_Channel_11 : JY5320Core.h
  • JY5320_Channel_12 : JY5320Core.h
  • JY5320_Channel_13 : JY5320Core.h
  • JY5320_Channel_14 : JY5320Core.h
  • JY5320_Channel_15 : JY5320Core.h
  • JY5320_Channel_16 : JY5320Core.h
  • JY5320_Channel_17 : JY5320Core.h
  • JY5320_Channel_18 : JY5320Core.h
  • JY5320_Channel_19 : JY5320Core.h
  • JY5320_Channel_2 : JY5320Core.h
  • JY5320_Channel_20 : JY5320Core.h
  • JY5320_Channel_21 : JY5320Core.h
  • JY5320_Channel_22 : JY5320Core.h
  • JY5320_Channel_23 : JY5320Core.h
  • JY5320_Channel_24 : JY5320Core.h
  • JY5320_Channel_25 : JY5320Core.h
  • JY5320_Channel_26 : JY5320Core.h
  • JY5320_Channel_27 : JY5320Core.h
  • JY5320_Channel_28 : JY5320Core.h
  • JY5320_Channel_29 : JY5320Core.h
  • JY5320_Channel_3 : JY5320Core.h
  • JY5320_Channel_30 : JY5320Core.h
  • JY5320_Channel_31 : JY5320Core.h
  • JY5320_Channel_4 : JY5320Core.h
  • JY5320_Channel_5 : JY5320Core.h
  • JY5320_Channel_6 : JY5320Core.h
  • JY5320_Channel_7 : JY5320Core.h
  • JY5320_Channel_8 : JY5320Core.h
  • JY5320_Channel_9 : JY5320Core.h
  • JY5320_CI0_SampleClock : JY5320Core.h
  • JY5320_CI1_SampleClock : JY5320Core.h
  • JY5320_CI_CheckBufferStatus() : JY5320Core.h
  • JY5320_CI_Continuous : JY5320Core.h
  • JY5320_CI_Count_Down : JY5320Core.h
  • JY5320_CI_Count_External : JY5320Core.h
  • JY5320_CI_Count_Up : JY5320Core.h
  • JY5320_CI_CounterEventSignalIdleState : JY5320Core.h
  • JY5320_CI_CounterEventSignalIdleState_High : JY5320Core.h
  • JY5320_CI_CounterEventSignalIdleState_Low : JY5320Core.h
  • JY5320_CI_EdgeCount : JY5320Core.h
  • JY5320_CI_EnableChannel() : JY5320Core.h
  • JY5320_CI_EncoderTwoPulse : JY5320Core.h
  • JY5320_CI_EncoderX1 : JY5320Core.h
  • JY5320_CI_EncoderX2 : JY5320Core.h
  • JY5320_CI_EncoderX4 : JY5320Core.h
  • JY5320_CI_ExternalClock : JY5320Core.h
  • JY5320_CI_Finite : JY5320Core.h
  • JY5320_CI_ImplicitClock : JY5320Core.h
  • JY5320_CI_InternalClock : JY5320Core.h
  • JY5320_CI_LevelState : JY5320Core.h
  • JY5320_CI_Measure_EdgeSeparation : JY5320Core.h
  • JY5320_CI_Measure_FrequencyOrPeriod : JY5320Core.h
  • JY5320_CI_Measure_PulseWidth : JY5320Core.h
  • JY5320_CI_Measure_SemiPeriod : JY5320Core.h
  • JY5320_CI_MeasureType : JY5320Core.h
  • JY5320_CI_ReadCountValues() : JY5320Core.h
  • JY5320_CI_ReadMeasureValues() : JY5320Core.h
  • JY5320_CI_ReadSingleCountValue() : JY5320Core.h
  • JY5320_CI_ReadSingleMeasureValue() : JY5320Core.h
  • JY5320_CI_SampleClock : JY5320Core.h
  • JY5320_CI_SampleMode : JY5320Core.h
  • JY5320_CI_SendSoftTrigger() : JY5320Core.h
  • JY5320_CI_SetAuxTerminal() : JY5320Core.h
  • JY5320_CI_SetCounterParament() : JY5320Core.h
  • JY5320_CI_SetCounterType() : JY5320Core.h
  • JY5320_CI_SetDigitalStartTrigger() : JY5320Core.h
  • JY5320_CI_SetEdgeCountEvent() : JY5320Core.h
  • JY5320_CI_SetFirstSampleClock() : JY5320Core.h
  • JY5320_CI_SetGateTerminal() : JY5320Core.h
  • JY5320_CI_SetMode() : JY5320Core.h
  • JY5320_CI_SetOutTerminal() : JY5320Core.h
  • JY5320_CI_SetPauseTriggerLevel() : JY5320Core.h
  • JY5320_CI_SetSampleClock() : JY5320Core.h
  • JY5320_CI_SetSamplesToAcquire() : JY5320Core.h
  • JY5320_CI_SetSignalReverse() : JY5320Core.h
  • JY5320_CI_SetSourceTerminal() : JY5320Core.h
  • JY5320_CI_SetStartingEdge() : JY5320Core.h
  • JY5320_CI_SetStartTriggerType() : JY5320Core.h
  • JY5320_CI_SetTimeBase() : JY5320Core.h
  • JY5320_CI_SetZReloadEnabled() : JY5320Core.h
  • JY5320_CI_Single : JY5320Core.h
  • JY5320_CI_Start() : JY5320Core.h
  • JY5320_CI_StartingEdge : JY5320Core.h
  • JY5320_CI_Stop() : JY5320Core.h
  • JY5320_CIO_0_StartTrig : JY5320Core.h
  • JY5320_CIO_100kHz : JY5320Core.h
  • JY5320_CIO_100MHz : JY5320Core.h
  • JY5320_CIO_1_StartTrig : JY5320Core.h
  • JY5320_CIO_5MHz : JY5320Core.h
  • JY5320_CIO_Digital : JY5320Core.h
  • JY5320_CIO_Immediately : JY5320Core.h
  • JY5320_CIO_Soft : JY5320Core.h
  • JY5320_CIO_TriggerType : JY5320Core.h
  • JY5320_Clock_PFI_0 : JY5320Core.h
  • JY5320_Clock_PFI_1 : JY5320Core.h
  • JY5320_Clock_PFI_10 : JY5320Core.h
  • JY5320_Clock_PFI_11 : JY5320Core.h
  • JY5320_Clock_PFI_12 : JY5320Core.h
  • JY5320_Clock_PFI_13 : JY5320Core.h
  • JY5320_Clock_PFI_14 : JY5320Core.h
  • JY5320_Clock_PFI_15 : JY5320Core.h
  • JY5320_Clock_PFI_2 : JY5320Core.h
  • JY5320_Clock_PFI_3 : JY5320Core.h
  • JY5320_Clock_PFI_4 : JY5320Core.h
  • JY5320_Clock_PFI_5 : JY5320Core.h
  • JY5320_Clock_PFI_6 : JY5320Core.h
  • JY5320_Clock_PFI_7 : JY5320Core.h
  • JY5320_Clock_PFI_8 : JY5320Core.h
  • JY5320_Clock_PFI_9 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_0 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_1 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_2 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_3 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_4 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_5 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_6 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_7 : JY5320Core.h
  • JY5320_Close() : JY5320Core.h
  • JY5320_CO_0_Output : JY5320Core.h
  • JY5320_CO_1_Output : JY5320Core.h
  • JY5320_CO_CheckBufferStatus() : JY5320Core.h
  • JY5320_CO_CheckCounterStatus() : JY5320Core.h
  • JY5320_CO_ContinuousNoWrapping : JY5320Core.h
  • JY5320_CO_ContinuousWrapping : JY5320Core.h
  • JY5320_CO_EnableChannel() : JY5320Core.h
  • JY5320_CO_Finite : JY5320Core.h
  • JY5320_CO_HighLevel : JY5320Core.h
  • JY5320_CO_IdleState : JY5320Core.h
  • JY5320_CO_LowLevel : JY5320Core.h
  • JY5320_CO_OUTMode : JY5320Core.h
  • JY5320_CO_SendSoftTrigger() : JY5320Core.h
  • JY5320_CO_SetCounterParament() : JY5320Core.h
  • JY5320_CO_SetDigitalStartTrigger() : JY5320Core.h
  • JY5320_CO_SetFrequency() : JY5320Core.h
  • JY5320_CO_SetFrequencyOnFly() : JY5320Core.h
  • JY5320_CO_SetMode() : JY5320Core.h
  • JY5320_CO_SetOutTerminal() : JY5320Core.h
  • JY5320_CO_SetSamplesToUpdate() : JY5320Core.h
  • JY5320_CO_SetSourceTerminal() : JY5320Core.h
  • JY5320_CO_SetStartTriggerType() : JY5320Core.h
  • JY5320_CO_SetTimeBase() : JY5320Core.h
  • JY5320_CO_Single : JY5320Core.h
  • JY5320_CO_Start() : JY5320Core.h
  • JY5320_CO_Stop() : JY5320Core.h
  • JY5320_CO_WaitUntilDone() : JY5320Core.h
  • JY5320_CO_WriteData() : JY5320Core.h
  • JY5320_CountDirection : JY5320Core.h
  • JY5320_CountTimeBase : JY5320Core.h
  • JY5320_DeviceHandle : JY5320Core.h
  • JY5320_DeviceProperty : JY5320Core.h
  • JY5320_DI_AddLines() : JY5320Core.h
  • JY5320_DI_ReadSinglePoint() : JY5320Core.h
  • JY5320_DI_ReadSinglePoint_U16() : JY5320Core.h
  • JY5320_DI_Start() : JY5320Core.h
  • JY5320_DI_Stop() : JY5320Core.h
  • JY5320_DigitalTriggerEdge : JY5320Core.h
  • JY5320_DigitalTriggerSource : JY5320Core.h
  • JY5320_DisableAICalibration() : JY5320Core.h
  • JY5320_DisconnectSignalRouting() : JY5320Core.h
  • JY5320_DO_AddLines() : JY5320Core.h
  • JY5320_DO_Start() : JY5320Core.h
  • JY5320_DO_Stop() : JY5320Core.h
  • JY5320_DO_WriteSinglePoint() : JY5320Core.h
  • JY5320_DO_WriteSinglePoint_U16() : JY5320Core.h
  • JY5320_Entering : JY5320Core.h
  • JY5320_External_Timebase : JY5320Core.h
  • JY5320_ExternalClockTerminal : JY5320Core.h
  • JY5320_Falling : JY5320Core.h
  • JY5320_FallingEdge : JY5320Core.h
  • JY5320_FallingSlope : JY5320Core.h
  • JY5320_GetDeviceID() : JY5320Core.h
  • JY5320_GetDeviceSerialNumber() : JY5320Core.h
  • JY5320_HighLevel : JY5320Core.h
  • JY5320_IN_CIO_100kHz : JY5320Core.h
  • JY5320_IN_CIO_100MHz : JY5320Core.h
  • JY5320_IN_CIO_5MHz : JY5320Core.h
  • JY5320_IN_CO_0_Output : JY5320Core.h
  • JY5320_IN_CO_1_Output : JY5320Core.h
  • JY5320_IN_PFI0 : JY5320Core.h
  • JY5320_IN_PFI1 : JY5320Core.h
  • JY5320_IN_PFI10 : JY5320Core.h
  • JY5320_IN_PFI11 : JY5320Core.h
  • JY5320_IN_PFI12 : JY5320Core.h
  • JY5320_IN_PFI13 : JY5320Core.h
  • JY5320_IN_PFI14 : JY5320Core.h
  • JY5320_IN_PFI15 : JY5320Core.h
  • JY5320_IN_PFI2 : JY5320Core.h
  • JY5320_IN_PFI3 : JY5320Core.h
  • JY5320_IN_PFI4 : JY5320Core.h
  • JY5320_IN_PFI5 : JY5320Core.h
  • JY5320_IN_PFI6 : JY5320Core.h
  • JY5320_IN_PFI7 : JY5320Core.h
  • JY5320_IN_PFI8 : JY5320Core.h
  • JY5320_IN_PFI9 : JY5320Core.h
  • JY5320_IN_PXI_Trig0 : JY5320Core.h
  • JY5320_IN_PXI_Trig1 : JY5320Core.h
  • JY5320_IN_PXI_Trig2 : JY5320Core.h
  • JY5320_IN_PXI_Trig3 : JY5320Core.h
  • JY5320_IN_PXI_Trig4 : JY5320Core.h
  • JY5320_IN_PXI_Trig5 : JY5320Core.h
  • JY5320_IN_PXI_Trig6 : JY5320Core.h
  • JY5320_IN_PXI_Trig7 : JY5320Core.h
  • JY5320_Independent : JY5320Core.h
  • JY5320_InputTerminal : JY5320Core.h
  • JY5320_Inter_AI_ReferenceTrig : JY5320Core.h
  • JY5320_Inter_AI_SampleClock : JY5320Core.h
  • JY5320_Inter_AI_StartTrig : JY5320Core.h
  • JY5320_Inter_CI0_SampleClock : JY5320Core.h
  • JY5320_Inter_CI1_SampleClock : JY5320Core.h
  • JY5320_Inter_CIO_0_StartTrig : JY5320Core.h
  • JY5320_Inter_CIO_1_StartTrig : JY5320Core.h
  • JY5320_Inter_CO_0_Output : JY5320Core.h
  • JY5320_Inter_CO_1_Output : JY5320Core.h
  • JY5320_Internal : JY5320Core.h
  • JY5320_Internal_Timebase_100K : JY5320Core.h
  • JY5320_Internal_Timebase_100M : JY5320Core.h
  • JY5320_Internal_Timebase_5M : JY5320Core.h
  • JY5320_Leaving : JY5320Core.h
  • JY5320_LowLevel : JY5320Core.h
  • JY5320_MASTER : JY5320Core.h
  • JY5320_Open() : JY5320Core.h
  • JY5320_OpenByAliasName() : JY5320Core.h
  • JY5320_PFI0 : JY5320Core.h
  • JY5320_PFI0_OUT : JY5320Core.h
  • JY5320_PFI1 : JY5320Core.h
  • JY5320_PFI10 : JY5320Core.h
  • JY5320_PFI10_OUT : JY5320Core.h
  • JY5320_PFI11 : JY5320Core.h
  • JY5320_PFI11_OUT : JY5320Core.h
  • JY5320_PFI12 : JY5320Core.h
  • JY5320_PFI12_OUT : JY5320Core.h
  • JY5320_PFI13 : JY5320Core.h
  • JY5320_PFI13_OUT : JY5320Core.h
  • JY5320_PFI14 : JY5320Core.h
  • JY5320_PFI14_OUT : JY5320Core.h
  • JY5320_PFI15 : JY5320Core.h
  • JY5320_PFI15_OUT : JY5320Core.h
  • JY5320_PFI1_OUT : JY5320Core.h
  • JY5320_PFI2 : JY5320Core.h
  • JY5320_PFI2_OUT : JY5320Core.h
  • JY5320_PFI3 : JY5320Core.h
  • JY5320_PFI3_OUT : JY5320Core.h
  • JY5320_PFI4 : JY5320Core.h
  • JY5320_PFI4_OUT : JY5320Core.h
  • JY5320_PFI5 : JY5320Core.h
  • JY5320_PFI5_OUT : JY5320Core.h
  • JY5320_PFI6 : JY5320Core.h
  • JY5320_PFI6_OUT : JY5320Core.h
  • JY5320_PFI7 : JY5320Core.h
  • JY5320_PFI7_OUT : JY5320Core.h
  • JY5320_PFI8 : JY5320Core.h
  • JY5320_PFI8_OUT : JY5320Core.h
  • JY5320_PFI9 : JY5320Core.h
  • JY5320_PFI9_OUT : JY5320Core.h
  • JY5320_PXI_Trig0 : JY5320Core.h
  • JY5320_PXI_Trig1 : JY5320Core.h
  • JY5320_PXI_Trig2 : JY5320Core.h
  • JY5320_PXI_Trig3 : JY5320Core.h
  • JY5320_PXI_Trig4 : JY5320Core.h
  • JY5320_PXI_Trig5 : JY5320Core.h
  • JY5320_PXI_Trig6 : JY5320Core.h
  • JY5320_PXI_Trig7 : JY5320Core.h
  • JY5320_PXIe_Clk100 : JY5320Core.h
  • JY5320_PXITrig0_OUT : JY5320Core.h
  • JY5320_PXITrig1_OUT : JY5320Core.h
  • JY5320_PXITrig2_OUT : JY5320Core.h
  • JY5320_PXITrig3_OUT : JY5320Core.h
  • JY5320_PXITrig4_OUT : JY5320Core.h
  • JY5320_PXITrig5_OUT : JY5320Core.h
  • JY5320_PXITrig6_OUT : JY5320Core.h
  • JY5320_PXITrig7_OUT : JY5320Core.h
  • JY5320_ReferenceClock : JY5320Core.h
  • JY5320_ReferenceTrigger : JY5320Core.h
  • JY5320_Rising : JY5320Core.h
  • JY5320_RisingEdge : JY5320Core.h
  • JY5320_RisingSlope : JY5320Core.h
  • JY5320_SetDeviceProperty() : JY5320Core.h
  • JY5320_SetDeviceReferenceClock() : JY5320Core.h
  • JY5320_SetDeviceStatusLed() : JY5320Core.h
  • JY5320_Signal_Destination : JY5320Core.h
  • JY5320_Signal_Source : JY5320Core.h
  • JY5320_SignalRouting() : JY5320Core.h
  • JY5320_SLAVE : JY5320Core.h
  • JY5320_StartTrigger : JY5320Core.h
  • JY5320_TriggerMode : JY5320Core.h


5320 C++ Programming Manual: File Members

  • JY5320_AI_BandWidth : JY5320Core.h
  • JY5320_AI_ClockSource : JY5320Core.h
  • JY5320_AI_SampleMode : JY5320Core.h
  • JY5320_AI_TriggerType : JY5320Core.h
  • JY5320_AnalogTriggerEdge : JY5320Core.h
  • JY5320_AnalogTriggerSource : JY5320Core.h
  • JY5320_AnalogWindowCondition : JY5320Core.h
  • JY5320_CI_CounterEventSignalIdleState : JY5320Core.h
  • JY5320_CI_LevelState : JY5320Core.h
  • JY5320_CI_MeasureType : JY5320Core.h
  • JY5320_CI_SampleClock : JY5320Core.h
  • JY5320_CI_SampleMode : JY5320Core.h
  • JY5320_CI_StartingEdge : JY5320Core.h
  • JY5320_CIO_TriggerType : JY5320Core.h
  • JY5320_CO_IdleState : JY5320Core.h
  • JY5320_CO_OUTMode : JY5320Core.h
  • JY5320_CountDirection : JY5320Core.h
  • JY5320_CountTimeBase : JY5320Core.h
  • JY5320_DeviceProperty : JY5320Core.h
  • JY5320_DigitalTriggerEdge : JY5320Core.h
  • JY5320_DigitalTriggerSource : JY5320Core.h
  • JY5320_ExternalClockTerminal : JY5320Core.h
  • JY5320_InputTerminal : JY5320Core.h
  • JY5320_ReferenceClock : JY5320Core.h
  • JY5320_Signal_Destination : JY5320Core.h
  • JY5320_Signal_Source : JY5320Core.h
  • JY5320_TriggerMode : JY5320Core.h


5320 C++ Programming Manual: File Members

- j -

  • JY5320_AI_ADC_Trig : JY5320Core.h
  • JY5320_AI_Analog : JY5320Core.h
  • JY5320_AI_BandWidth_220K : JY5320Core.h
  • JY5320_AI_BandWidth_25K : JY5320Core.h
  • JY5320_AI_Continuous : JY5320Core.h
  • JY5320_AI_Digital : JY5320Core.h
  • JY5320_AI_ExternalClock : JY5320Core.h
  • JY5320_AI_Finite : JY5320Core.h
  • JY5320_AI_Immediately : JY5320Core.h
  • JY5320_AI_InternalClock : JY5320Core.h
  • JY5320_AI_ReferenceTrig : JY5320Core.h
  • JY5320_AI_SampleClock : JY5320Core.h
  • JY5320_AI_Single : JY5320Core.h
  • JY5320_AI_Soft : JY5320Core.h
  • JY5320_AI_StartTrig : JY5320Core.h
  • JY5320_AnyEdge : JY5320Core.h
  • JY5320_Channel_0 : JY5320Core.h
  • JY5320_Channel_1 : JY5320Core.h
  • JY5320_Channel_10 : JY5320Core.h
  • JY5320_Channel_11 : JY5320Core.h
  • JY5320_Channel_12 : JY5320Core.h
  • JY5320_Channel_13 : JY5320Core.h
  • JY5320_Channel_14 : JY5320Core.h
  • JY5320_Channel_15 : JY5320Core.h
  • JY5320_Channel_16 : JY5320Core.h
  • JY5320_Channel_17 : JY5320Core.h
  • JY5320_Channel_18 : JY5320Core.h
  • JY5320_Channel_19 : JY5320Core.h
  • JY5320_Channel_2 : JY5320Core.h
  • JY5320_Channel_20 : JY5320Core.h
  • JY5320_Channel_21 : JY5320Core.h
  • JY5320_Channel_22 : JY5320Core.h
  • JY5320_Channel_23 : JY5320Core.h
  • JY5320_Channel_24 : JY5320Core.h
  • JY5320_Channel_25 : JY5320Core.h
  • JY5320_Channel_26 : JY5320Core.h
  • JY5320_Channel_27 : JY5320Core.h
  • JY5320_Channel_28 : JY5320Core.h
  • JY5320_Channel_29 : JY5320Core.h
  • JY5320_Channel_3 : JY5320Core.h
  • JY5320_Channel_30 : JY5320Core.h
  • JY5320_Channel_31 : JY5320Core.h
  • JY5320_Channel_4 : JY5320Core.h
  • JY5320_Channel_5 : JY5320Core.h
  • JY5320_Channel_6 : JY5320Core.h
  • JY5320_Channel_7 : JY5320Core.h
  • JY5320_Channel_8 : JY5320Core.h
  • JY5320_Channel_9 : JY5320Core.h
  • JY5320_CI0_SampleClock : JY5320Core.h
  • JY5320_CI1_SampleClock : JY5320Core.h
  • JY5320_CI_Continuous : JY5320Core.h
  • JY5320_CI_Count_Down : JY5320Core.h
  • JY5320_CI_Count_External : JY5320Core.h
  • JY5320_CI_Count_Up : JY5320Core.h
  • JY5320_CI_CounterEventSignalIdleState_High : JY5320Core.h
  • JY5320_CI_CounterEventSignalIdleState_Low : JY5320Core.h
  • JY5320_CI_EdgeCount : JY5320Core.h
  • JY5320_CI_EncoderTwoPulse : JY5320Core.h
  • JY5320_CI_EncoderX1 : JY5320Core.h
  • JY5320_CI_EncoderX2 : JY5320Core.h
  • JY5320_CI_EncoderX4 : JY5320Core.h
  • JY5320_CI_ExternalClock : JY5320Core.h
  • JY5320_CI_Finite : JY5320Core.h
  • JY5320_CI_ImplicitClock : JY5320Core.h
  • JY5320_CI_InternalClock : JY5320Core.h
  • JY5320_CI_Measure_EdgeSeparation : JY5320Core.h
  • JY5320_CI_Measure_FrequencyOrPeriod : JY5320Core.h
  • JY5320_CI_Measure_PulseWidth : JY5320Core.h
  • JY5320_CI_Measure_SemiPeriod : JY5320Core.h
  • JY5320_CI_Single : JY5320Core.h
  • JY5320_CIO_0_StartTrig : JY5320Core.h
  • JY5320_CIO_100kHz : JY5320Core.h
  • JY5320_CIO_100MHz : JY5320Core.h
  • JY5320_CIO_1_StartTrig : JY5320Core.h
  • JY5320_CIO_5MHz : JY5320Core.h
  • JY5320_CIO_Digital : JY5320Core.h
  • JY5320_CIO_Immediately : JY5320Core.h
  • JY5320_CIO_Soft : JY5320Core.h
  • JY5320_Clock_PFI_0 : JY5320Core.h
  • JY5320_Clock_PFI_1 : JY5320Core.h
  • JY5320_Clock_PFI_10 : JY5320Core.h
  • JY5320_Clock_PFI_11 : JY5320Core.h
  • JY5320_Clock_PFI_12 : JY5320Core.h
  • JY5320_Clock_PFI_13 : JY5320Core.h
  • JY5320_Clock_PFI_14 : JY5320Core.h
  • JY5320_Clock_PFI_15 : JY5320Core.h
  • JY5320_Clock_PFI_2 : JY5320Core.h
  • JY5320_Clock_PFI_3 : JY5320Core.h
  • JY5320_Clock_PFI_4 : JY5320Core.h
  • JY5320_Clock_PFI_5 : JY5320Core.h
  • JY5320_Clock_PFI_6 : JY5320Core.h
  • JY5320_Clock_PFI_7 : JY5320Core.h
  • JY5320_Clock_PFI_8 : JY5320Core.h
  • JY5320_Clock_PFI_9 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_0 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_1 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_2 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_3 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_4 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_5 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_6 : JY5320Core.h
  • JY5320_Clock_PXI_Trig_7 : JY5320Core.h
  • JY5320_CO_0_Output : JY5320Core.h
  • JY5320_CO_1_Output : JY5320Core.h
  • JY5320_CO_ContinuousNoWrapping : JY5320Core.h
  • JY5320_CO_ContinuousWrapping : JY5320Core.h
  • JY5320_CO_Finite : JY5320Core.h
  • JY5320_CO_HighLevel : JY5320Core.h
  • JY5320_CO_LowLevel : JY5320Core.h
  • JY5320_CO_Single : JY5320Core.h
  • JY5320_Entering : JY5320Core.h
  • JY5320_External_Timebase : JY5320Core.h
  • JY5320_Falling : JY5320Core.h
  • JY5320_FallingEdge : JY5320Core.h
  • JY5320_FallingSlope : JY5320Core.h
  • JY5320_HighLevel : JY5320Core.h
  • JY5320_IN_CIO_100kHz : JY5320Core.h
  • JY5320_IN_CIO_100MHz : JY5320Core.h
  • JY5320_IN_CIO_5MHz : JY5320Core.h
  • JY5320_IN_CO_0_Output : JY5320Core.h
  • JY5320_IN_CO_1_Output : JY5320Core.h
  • JY5320_IN_PFI0 : JY5320Core.h
  • JY5320_IN_PFI1 : JY5320Core.h
  • JY5320_IN_PFI10 : JY5320Core.h
  • JY5320_IN_PFI11 : JY5320Core.h
  • JY5320_IN_PFI12 : JY5320Core.h
  • JY5320_IN_PFI13 : JY5320Core.h
  • JY5320_IN_PFI14 : JY5320Core.h
  • JY5320_IN_PFI15 : JY5320Core.h
  • JY5320_IN_PFI2 : JY5320Core.h
  • JY5320_IN_PFI3 : JY5320Core.h
  • JY5320_IN_PFI4 : JY5320Core.h
  • JY5320_IN_PFI5 : JY5320Core.h
  • JY5320_IN_PFI6 : JY5320Core.h
  • JY5320_IN_PFI7 : JY5320Core.h
  • JY5320_IN_PFI8 : JY5320Core.h
  • JY5320_IN_PFI9 : JY5320Core.h
  • JY5320_IN_PXI_Trig0 : JY5320Core.h
  • JY5320_IN_PXI_Trig1 : JY5320Core.h
  • JY5320_IN_PXI_Trig2 : JY5320Core.h
  • JY5320_IN_PXI_Trig3 : JY5320Core.h
  • JY5320_IN_PXI_Trig4 : JY5320Core.h
  • JY5320_IN_PXI_Trig5 : JY5320Core.h
  • JY5320_IN_PXI_Trig6 : JY5320Core.h
  • JY5320_IN_PXI_Trig7 : JY5320Core.h
  • JY5320_Independent : JY5320Core.h
  • JY5320_Inter_AI_ReferenceTrig : JY5320Core.h
  • JY5320_Inter_AI_SampleClock : JY5320Core.h
  • JY5320_Inter_AI_StartTrig : JY5320Core.h
  • JY5320_Inter_CI0_SampleClock : JY5320Core.h
  • JY5320_Inter_CI1_SampleClock : JY5320Core.h
  • JY5320_Inter_CIO_0_StartTrig : JY5320Core.h
  • JY5320_Inter_CIO_1_StartTrig : JY5320Core.h
  • JY5320_Inter_CO_0_Output : JY5320Core.h
  • JY5320_Inter_CO_1_Output : JY5320Core.h
  • JY5320_Internal : JY5320Core.h
  • JY5320_Internal_Timebase_100K : JY5320Core.h
  • JY5320_Internal_Timebase_100M : JY5320Core.h
  • JY5320_Internal_Timebase_5M : JY5320Core.h
  • JY5320_Leaving : JY5320Core.h
  • JY5320_LowLevel : JY5320Core.h
  • JY5320_MASTER : JY5320Core.h
  • JY5320_PFI0 : JY5320Core.h
  • JY5320_PFI0_OUT : JY5320Core.h
  • JY5320_PFI1 : JY5320Core.h
  • JY5320_PFI10 : JY5320Core.h
  • JY5320_PFI10_OUT : JY5320Core.h
  • JY5320_PFI11 : JY5320Core.h
  • JY5320_PFI11_OUT : JY5320Core.h
  • JY5320_PFI12 : JY5320Core.h
  • JY5320_PFI12_OUT : JY5320Core.h
  • JY5320_PFI13 : JY5320Core.h
  • JY5320_PFI13_OUT : JY5320Core.h
  • JY5320_PFI14 : JY5320Core.h
  • JY5320_PFI14_OUT : JY5320Core.h
  • JY5320_PFI15 : JY5320Core.h
  • JY5320_PFI15_OUT : JY5320Core.h
  • JY5320_PFI1_OUT : JY5320Core.h
  • JY5320_PFI2 : JY5320Core.h
  • JY5320_PFI2_OUT : JY5320Core.h
  • JY5320_PFI3 : JY5320Core.h
  • JY5320_PFI3_OUT : JY5320Core.h
  • JY5320_PFI4 : JY5320Core.h
  • JY5320_PFI4_OUT : JY5320Core.h
  • JY5320_PFI5 : JY5320Core.h
  • JY5320_PFI5_OUT : JY5320Core.h
  • JY5320_PFI6 : JY5320Core.h
  • JY5320_PFI6_OUT : JY5320Core.h
  • JY5320_PFI7 : JY5320Core.h
  • JY5320_PFI7_OUT : JY5320Core.h
  • JY5320_PFI8 : JY5320Core.h
  • JY5320_PFI8_OUT : JY5320Core.h
  • JY5320_PFI9 : JY5320Core.h
  • JY5320_PFI9_OUT : JY5320Core.h
  • JY5320_PXI_Trig0 : JY5320Core.h
  • JY5320_PXI_Trig1 : JY5320Core.h
  • JY5320_PXI_Trig2 : JY5320Core.h
  • JY5320_PXI_Trig3 : JY5320Core.h
  • JY5320_PXI_Trig4 : JY5320Core.h
  • JY5320_PXI_Trig5 : JY5320Core.h
  • JY5320_PXI_Trig6 : JY5320Core.h
  • JY5320_PXI_Trig7 : JY5320Core.h
  • JY5320_PXIe_Clk100 : JY5320Core.h
  • JY5320_PXITrig0_OUT : JY5320Core.h
  • JY5320_PXITrig1_OUT : JY5320Core.h
  • JY5320_PXITrig2_OUT : JY5320Core.h
  • JY5320_PXITrig3_OUT : JY5320Core.h
  • JY5320_PXITrig4_OUT : JY5320Core.h
  • JY5320_PXITrig5_OUT : JY5320Core.h
  • JY5320_PXITrig6_OUT : JY5320Core.h
  • JY5320_PXITrig7_OUT : JY5320Core.h
  • JY5320_ReferenceTrigger : JY5320Core.h
  • JY5320_Rising : JY5320Core.h
  • JY5320_RisingEdge : JY5320Core.h
  • JY5320_RisingSlope : JY5320Core.h
  • JY5320_SLAVE : JY5320Core.h
  • JY5320_StartTrigger : JY5320Core.h


5320 C++ Programming Manual: File Members

- j -

  • JY5320_AI_CheckBufferStatus() : JY5320Core.h
  • JY5320_AI_EnableChannel() : JY5320Core.h
  • JY5320_AI_ReadData() : JY5320Core.h
  • JY5320_AI_ReadRawData_U16() : JY5320Core.h
  • JY5320_AI_ReadRawData_U32() : JY5320Core.h
  • JY5320_AI_ReadSinglePoint() : JY5320Core.h
  • JY5320_AI_SendSoftTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogEdgeReferenceTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogEdgeStartTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogHysteresisReferenceTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogHysteresisStartTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogWindowReferenceTrigger() : JY5320Core.h
  • JY5320_AI_SetAnalogWindowStartTrigger() : JY5320Core.h
  • JY5320_AI_SetDigitalReferenceTrigger() : JY5320Core.h
  • JY5320_AI_SetDigitalStartTrigger() : JY5320Core.h
  • JY5320_AI_SetDSMode() : JY5320Core.h
  • JY5320_AI_SetMode() : JY5320Core.h
  • JY5320_AI_SetPreTriggerSamples() : JY5320Core.h
  • JY5320_AI_SetReferenceTriggerType() : JY5320Core.h
  • JY5320_AI_SetReTriggerCount() : JY5320Core.h
  • JY5320_AI_SetSampleClock() : JY5320Core.h
  • JY5320_AI_SetSampleRate() : JY5320Core.h
  • JY5320_AI_SetSamplesToAcquire() : JY5320Core.h
  • JY5320_AI_SetStartTriggerType() : JY5320Core.h
  • JY5320_AI_Start() : JY5320Core.h
  • JY5320_AI_Stop() : JY5320Core.h
  • JY5320_AI_WaitUntilDone() : JY5320Core.h
  • JY5320_CI_CheckBufferStatus() : JY5320Core.h
  • JY5320_CI_EnableChannel() : JY5320Core.h
  • JY5320_CI_ReadCountValues() : JY5320Core.h
  • JY5320_CI_ReadMeasureValues() : JY5320Core.h
  • JY5320_CI_ReadSingleCountValue() : JY5320Core.h
  • JY5320_CI_ReadSingleMeasureValue() : JY5320Core.h
  • JY5320_CI_SendSoftTrigger() : JY5320Core.h
  • JY5320_CI_SetAuxTerminal() : JY5320Core.h
  • JY5320_CI_SetCounterParament() : JY5320Core.h
  • JY5320_CI_SetCounterType() : JY5320Core.h
  • JY5320_CI_SetDigitalStartTrigger() : JY5320Core.h
  • JY5320_CI_SetEdgeCountEvent() : JY5320Core.h
  • JY5320_CI_SetFirstSampleClock() : JY5320Core.h
  • JY5320_CI_SetGateTerminal() : JY5320Core.h
  • JY5320_CI_SetMode() : JY5320Core.h
  • JY5320_CI_SetOutTerminal() : JY5320Core.h
  • JY5320_CI_SetPauseTriggerLevel() : JY5320Core.h
  • JY5320_CI_SetSampleClock() : JY5320Core.h
  • JY5320_CI_SetSamplesToAcquire() : JY5320Core.h
  • JY5320_CI_SetSignalReverse() : JY5320Core.h
  • JY5320_CI_SetSourceTerminal() : JY5320Core.h
  • JY5320_CI_SetStartingEdge() : JY5320Core.h
  • JY5320_CI_SetStartTriggerType() : JY5320Core.h
  • JY5320_CI_SetTimeBase() : JY5320Core.h
  • JY5320_CI_SetZReloadEnabled() : JY5320Core.h
  • JY5320_CI_Start() : JY5320Core.h
  • JY5320_CI_Stop() : JY5320Core.h
  • JY5320_Close() : JY5320Core.h
  • JY5320_CO_CheckBufferStatus() : JY5320Core.h
  • JY5320_CO_CheckCounterStatus() : JY5320Core.h
  • JY5320_CO_EnableChannel() : JY5320Core.h
  • JY5320_CO_SendSoftTrigger() : JY5320Core.h
  • JY5320_CO_SetCounterParament() : JY5320Core.h
  • JY5320_CO_SetDigitalStartTrigger() : JY5320Core.h
  • JY5320_CO_SetFrequency() : JY5320Core.h
  • JY5320_CO_SetFrequencyOnFly() : JY5320Core.h
  • JY5320_CO_SetMode() : JY5320Core.h
  • JY5320_CO_SetOutTerminal() : JY5320Core.h
  • JY5320_CO_SetSamplesToUpdate() : JY5320Core.h
  • JY5320_CO_SetSourceTerminal() : JY5320Core.h
  • JY5320_CO_SetStartTriggerType() : JY5320Core.h
  • JY5320_CO_SetTimeBase() : JY5320Core.h
  • JY5320_CO_Start() : JY5320Core.h
  • JY5320_CO_Stop() : JY5320Core.h
  • JY5320_CO_WaitUntilDone() : JY5320Core.h
  • JY5320_CO_WriteData() : JY5320Core.h
  • JY5320_DI_AddLines() : JY5320Core.h
  • JY5320_DI_ReadSinglePoint() : JY5320Core.h
  • JY5320_DI_ReadSinglePoint_U16() : JY5320Core.h
  • JY5320_DI_Start() : JY5320Core.h
  • JY5320_DI_Stop() : JY5320Core.h
  • JY5320_DisableAICalibration() : JY5320Core.h
  • JY5320_DisconnectSignalRouting() : JY5320Core.h
  • JY5320_DO_AddLines() : JY5320Core.h
  • JY5320_DO_Start() : JY5320Core.h
  • JY5320_DO_Stop() : JY5320Core.h
  • JY5320_DO_WriteSinglePoint() : JY5320Core.h
  • JY5320_DO_WriteSinglePoint_U16() : JY5320Core.h
  • JY5320_GetDeviceID() : JY5320Core.h
  • JY5320_GetDeviceSerialNumber() : JY5320Core.h
  • JY5320_Open() : JY5320Core.h
  • JY5320_OpenByAliasName() : JY5320Core.h
  • JY5320_SetDeviceProperty() : JY5320Core.h
  • JY5320_SetDeviceReferenceClock() : JY5320Core.h
  • JY5320_SetDeviceStatusLed() : JY5320Core.h
  • JY5320_SignalRouting() : JY5320Core.h


5320 C++ Programming Manual: File Members

  • JY5320_DeviceHandle : JY5320Core.h


5320 C++ Programming Manual: Main Page

5320 C++ Programming Manual Documentation